aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:11:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-28 17:11:33 +0000
commite42ce61cd272340b486ab5e7200bf3d679fb1463 (patch)
tree89e760efa6edd1df2d93af65663c6ff75b4bf7e7 /devel
parent81cbd91898cba227b63d060f09544160ca9c6f57 (diff)
downloadports-e42ce61cd272340b486ab5e7200bf3d679fb1463.tar.gz
ports-e42ce61cd272340b486ab5e7200bf3d679fb1463.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-autobox/Makefile25
-rw-r--r--devel/p5-autobox/distinfo3
-rw-r--r--devel/p5-autobox/pkg-descr5
-rw-r--r--devel/p5-autobox/pkg-plist8
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cfed568284b0..d52655b7d5be 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2052,6 +2052,7 @@
SUBDIR += p5-ZML
SUBDIR += p5-accessors
SUBDIR += p5-aliased
+ SUBDIR += p5-autobox
SUBDIR += p5-base
SUBDIR += p5-boolean
SUBDIR += p5-capitalization
diff --git a/devel/p5-autobox/Makefile b/devel/p5-autobox/Makefile
new file mode 100644
index 000000000000..a3a4423ebf24
--- /dev/null
+++ b/devel/p5-autobox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-autobox
+# Date created: 25 July 2009
+# Whom: Bill Brinzer <bill.brinzer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autobox
+PORTVERSION= 2.55
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/C/CH/CHOCOLATE/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bill.brinzer@gmail.com
+COMMENT= Call methods on native Perl types
+
+BUILD_DEPENDS= p5-Scope-Guard>=0.03:${PORTSDIR}/devel/p5-Scope-Guard
+RUN_DEPENDS= p5-Scope-Guard>=0.03:${PORTSDIR}/devel/p5-Scope-Guard
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= autobox.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-autobox/distinfo b/devel/p5-autobox/distinfo
new file mode 100644
index 000000000000..b113e156a759
--- /dev/null
+++ b/devel/p5-autobox/distinfo
@@ -0,0 +1,3 @@
+MD5 (autobox-2.55.tar.gz) = d2813439a0da9b048cc1793af05b2144
+SHA256 (autobox-2.55.tar.gz) = f0c79b2acacb002e15b3869f1e218f6540723ade1d409846cc32a7bdf047d6cd
+SIZE (autobox-2.55.tar.gz) = 66395
diff --git a/devel/p5-autobox/pkg-descr b/devel/p5-autobox/pkg-descr
new file mode 100644
index 000000000000..42fb5c5baab2
--- /dev/null
+++ b/devel/p5-autobox/pkg-descr
@@ -0,0 +1,5 @@
+The autobox pragma allows methods to be called on integers, floats, strings,
+arrays, hashes, and code references in exactly the same manner as blessed
+references.
+
+WWW: http://search.cpan.org/dist/autobox/
diff --git a/devel/p5-autobox/pkg-plist b/devel/p5-autobox/pkg-plist
new file mode 100644
index 000000000000..f8cd1e92dc74
--- /dev/null
+++ b/devel/p5-autobox/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/mach/auto/autobox/.packlist
+%%SITE_PERL%%/mach/auto/autobox/autobox.bs
+%%SITE_PERL%%/mach/auto/autobox/autobox.so
+%%SITE_PERL%%/mach/autobox.pm
+%%SITE_PERL%%/mach/autobox.pod
+%%SITE_PERL%%/mach/autobox/universal.pm
+@dirrmtry %%SITE_PERL%%/mach/autobox
+@dirrmtry %%SITE_PERL%%/mach/auto/autobox