aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-09-14 10:50:16 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-09-14 10:50:16 +0000
commitf564808abbad60f2b82c72a5cd7a8c258d0ba3a1 (patch)
treeaa17e4b209477cc709213adf4b7fb860b363b5db /devel
parentc30c441cba1d5eb364f087cb7b466a4deb8d747d (diff)
downloadports-f564808abbad60f2b82c72a5cd7a8c258d0ba3a1.tar.gz
ports-f564808abbad60f2b82c72a5cd7a8c258d0ba3a1.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/mq4cpp/Makefile1
-rw-r--r--devel/mq4cpp/files/patch-include_Socket.h11
-rw-r--r--devel/mq4cpp/files/patch-include_Trace.h22
3 files changed, 23 insertions, 11 deletions
diff --git a/devel/mq4cpp/Makefile b/devel/mq4cpp/Makefile
index 9396b3f9c45a..08d4f776f8d0 100644
--- a/devel/mq4cpp/Makefile
+++ b/devel/mq4cpp/Makefile
@@ -14,6 +14,7 @@ USE_AUTOTOOLS= libtool
USES= pathfix pkgconfig
USE_GNOME= ltverhack
USE_BZIP2= yes
+USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/devel/mq4cpp/files/patch-include_Socket.h b/devel/mq4cpp/files/patch-include_Socket.h
new file mode 100644
index 000000000000..233edf768f33
--- /dev/null
+++ b/devel/mq4cpp/files/patch-include_Socket.h
@@ -0,0 +1,11 @@
+--- include/Socket.h.orig 2013-09-14 18:46:04.000000000 +0800
++++ include/Socket.h 2013-09-14 18:46:17.000000000 +0800
+@@ -30,6 +30,8 @@
+ #else
+ #include <netinet/in.h>
+ #include <sys/socket.h>
++#include <sys/select.h>
++#include <unistd.h>
+ typedef int SOCKET;
+ #endif
+
diff --git a/devel/mq4cpp/files/patch-include_Trace.h b/devel/mq4cpp/files/patch-include_Trace.h
index 28b400e13e49..b28477600f8a 100644
--- a/devel/mq4cpp/files/patch-include_Trace.h
+++ b/devel/mq4cpp/files/patch-include_Trace.h
@@ -1,11 +1,11 @@
---- include/Trace.h.orig Sat Mar 17 01:42:59 2007
-+++ include/Trace.h Thu Aug 9 17:17:25 2007
-@@ -92,7 +92,7 @@
- }
- #else
- #define TRACE(a) \
-- cout << __FILE__ << "(" << __LINE__ << ") #" << (int)pthread_self() << ": " << a << endl;
-+ cout << __FILE__ << "(" << __LINE__ << ") #" << pthread_self() << ": " << a << endl;
- #endif
- #else
- #define TRACE(a) ;
+--- include/Trace.h.orig 2013-09-14 18:46:21.000000000 +0800
++++ include/Trace.h 2013-09-14 18:46:41.000000000 +0800
+@@ -92,7 +92,7 @@ class DebugStream : public ostream
+ }
+ #else
+ #define TRACE(a) \
+- cout << __FILE__ << "(" << __LINE__ << ") #" << (int)pthread_self() << ": " << a << endl;
++ cout << __FILE__ << "(" << __LINE__ << ") #" << pthread_self() << ": " << a << endl;
+ #endif
+ #else
+ #define TRACE(a) ;