aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-03-05 13:50:15 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-03-05 13:50:15 +0000
commitf8dd2d24ba57121527dccf5932390c0de765042e (patch)
tree9e8179965718a170779c7b6e9f79e8e2d7945c0b /devel
parent428b6bbc0ca91e6cb620f0099e3498ae6d37099c (diff)
New port: devel/py-atomicwrites
Atomic file writes library for Python, featuring race-free assertions, Windows support (although untested) and simple high level API. WWW: https://github.com/untitaker/python-atomicwrites PR: 198275 Submitted by: Maxim Filimonov <che@bein.link>
Notes
Notes: svn path=/head/; revision=380494
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-atomicwrites/Makefile18
-rw-r--r--devel/py-atomicwrites/distinfo2
-rw-r--r--devel/py-atomicwrites/pkg-descr5
4 files changed, 26 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5be936a4a09c..33724f68f50b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3700,6 +3700,7 @@
SUBDIR += py-astroid
SUBDIR += py-async
SUBDIR += py-asyncio
+ SUBDIR += py-atomicwrites
SUBDIR += py-avro
SUBDIR += py-babel
SUBDIR += py-babelfish
diff --git a/devel/py-atomicwrites/Makefile b/devel/py-atomicwrites/Makefile
new file mode 100644
index 000000000000..024ef563686d
--- /dev/null
+++ b/devel/py-atomicwrites/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= atomicwrites
+PORTVERSION= 0.1.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= che@bein.link
+COMMENT= Atomic file writes library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-atomicwrites/distinfo b/devel/py-atomicwrites/distinfo
new file mode 100644
index 000000000000..1ab232b1a7a0
--- /dev/null
+++ b/devel/py-atomicwrites/distinfo
@@ -0,0 +1,2 @@
+SHA256 (atomicwrites-0.1.4.tar.gz) = 6fc694e318b46eec816c937c081a9ba05960967d77b81758d62352f4e6f108cc
+SIZE (atomicwrites-0.1.4.tar.gz) = 13650
diff --git a/devel/py-atomicwrites/pkg-descr b/devel/py-atomicwrites/pkg-descr
new file mode 100644
index 000000000000..fe4180125533
--- /dev/null
+++ b/devel/py-atomicwrites/pkg-descr
@@ -0,0 +1,5 @@
+Atomic file writes library for Python, featuring race-free
+assertions, Windows support (although untested) and simple
+high level API.
+
+WWW: https://github.com/untitaker/python-atomicwrites