aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-05 16:15:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-05 16:15:34 +0000
commitf9c16871babe7db64a8d105a134c5d76e6382365 (patch)
tree50588437677e7296e2252145db6ab92944c929f5 /devel
parenta839b0da6c571680213d223a57f48d0968327238 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-Wrest/Makefile27
-rw-r--r--devel/p5-Config-Wrest/distinfo3
-rw-r--r--devel/p5-Config-Wrest/pkg-descr12
-rw-r--r--devel/p5-Config-Wrest/pkg-plist9
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9e55c975a86b..1fc4b68f313a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1308,6 +1308,7 @@
SUBDIR += p5-Config-Simple
SUBDIR += p5-Config-Std
SUBDIR += p5-Config-Tiny
+ SUBDIR += p5-Config-Wrest
SUBDIR += p5-Config-YAML
SUBDIR += p5-ConfigReader
SUBDIR += p5-ConfigReader-Simple
diff --git a/devel/p5-Config-Wrest/Makefile b/devel/p5-Config-Wrest/Makefile
new file mode 100644
index 000000000000..6af90500af83
--- /dev/null
+++ b/devel/p5-Config-Wrest/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Config-Wrest
+# Date created: 02 April 2010
+# Whom: John Alden + Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Wrest
+PORTVERSION= 1.036
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Perl module for reading and writing configuration data
+
+RUN_DEPENDS= p5-Log-Trace>0:${PORTSDIR}/devel/p5-Log-Trace \
+ p5-Test-Assertions>0:${PORTSDIR}/devel/p5-Test-Assertions
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Config::Wrest.3 \
+ Data::Serializer::Config::Wrest.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Wrest/distinfo b/devel/p5-Config-Wrest/distinfo
new file mode 100644
index 000000000000..736d7c321fd8
--- /dev/null
+++ b/devel/p5-Config-Wrest/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-Wrest-1.036.tar.gz) = de9058baf34f741a834744a76f2204c1
+SHA256 (Config-Wrest-1.036.tar.gz) = 2cee0a67176dea14574870beb2dfa8d38323b0af0ed8358c849385500bdc536b
+SIZE (Config-Wrest-1.036.tar.gz) = 39516
diff --git a/devel/p5-Config-Wrest/pkg-descr b/devel/p5-Config-Wrest/pkg-descr
new file mode 100644
index 000000000000..9b36223b19f7
--- /dev/null
+++ b/devel/p5-Config-Wrest/pkg-descr
@@ -0,0 +1,12 @@
+This module allows you to read configuration data written in a
+human-readable and easily-editable text format and access it as
+a perl data structure. It also allows you to write configuration
+data from perl back to this format.
+
+The data format allows key/value pairs, comments, escaping of
+unprintable or problematic characters, sensible whitespace
+handling, support for Unicode data, nested sections, or blocks,
+of configuration data.
+
+Author: British Broadcasting Corporation
+WWW: http://search.cpan.org/dist/Config-Wrest/
diff --git a/devel/p5-Config-Wrest/pkg-plist b/devel/p5-Config-Wrest/pkg-plist
new file mode 100644
index 000000000000..1872aea440e1
--- /dev/null
+++ b/devel/p5-Config-Wrest/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Config/Wrest.pm
+%%SITE_PERL%%/Data/Serializer/Config/Wrest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Wrest/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Wrest
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrmtry %%SITE_PERL%%/Data/Serializer/Config
+@dirrmtry %%SITE_PERL%%/Data/Serializer
+@dirrmtry %%SITE_PERL%%/Data
+@dirrmtry %%SITE_PERL%%/Config