aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-12 22:43:24 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-12 22:43:24 +0000
commitfe7d35de728fff452daca23b8427e70bc3a5da09 (patch)
tree4d79b02cf6bd1ff0e1a0e3a975a715f4e2ad7992 /devel
parent62287039dd15c6eba0e547cbdbf375996852d11b (diff)
downloadports-fe7d35de728fff452daca23b8427e70bc3a5da09.tar.gz
ports-fe7d35de728fff452daca23b8427e70bc3a5da09.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/deforaos-libsystem/Makefile9
-rw-r--r--devel/libbde/Makefile5
-rw-r--r--devel/libbde/pkg-descr2
-rw-r--r--devel/libqcow/Makefile3
-rw-r--r--devel/libsmraw/Makefile6
5 files changed, 19 insertions, 6 deletions
diff --git a/devel/deforaos-libsystem/Makefile b/devel/deforaos-libsystem/Makefile
index d387749d4f40..8d27058ec7b9 100644
--- a/devel/deforaos-libsystem/Makefile
+++ b/devel/deforaos-libsystem/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libsystem
PORTVERSION= 0.1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.defora.org/os/download/download/3527/
DISTNAME= libSystem-${PORTVERSION}
@@ -16,10 +16,15 @@ LICENSE= GPLv3
USES= pkgconfig
USE_LDCONFIG= yes
+USE_OPENSSL= yes
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
MAKE_ARGS+= PREFIX=${PREFIX}
post-patch:
- ${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
+ ${REINPLACE_CMD} 's|/lib/|/libdata/|g' \
${WRKSRC}/data/pkgconfig.sh
+ ${REINPLACE_CMD} 's|CPPFLAGS=|CPPFLAGS+=|' \
+ ${WRKSRC}/src/Makefile
.include <bsd.port.mk>
diff --git a/devel/libbde/Makefile b/devel/libbde/Makefile
index 5002c7b7dac7..97fa0c258443 100644
--- a/devel/libbde/Makefile
+++ b/devel/libbde/Makefile
@@ -3,8 +3,9 @@
PORTNAME= libbde
DISTVERSION= alpha-20141023
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= https://googledrive.com/host/0B3fBvzttpiiSX2VCRk16TnpDd0U/ \
+MASTER_SITES= https://github.com/libyal/libbde/releases/download/${PORTVERSION:E}/ \
LOCAL/antoine
MAINTAINER= antoine@FreeBSD.org
@@ -18,6 +19,8 @@ USES= fuse gettext iconv libtool pathfix pkgconfig python:2
USE_OPENSSL= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
PORTDOCS= AUTHORS ChangeLog
diff --git a/devel/libbde/pkg-descr b/devel/libbde/pkg-descr
index 239d779bd388..1a420d08019c 100644
--- a/devel/libbde/pkg-descr
+++ b/devel/libbde/pkg-descr
@@ -1,4 +1,4 @@
Library and tools to access the BitLocker Drive Encryption (BDE) encrypted
volumes.
-WWW: http://code.google.com/p/libbde/
+WWW: https://github.com/libyal/libbde
diff --git a/devel/libqcow/Makefile b/devel/libqcow/Makefile
index be2f7fc9f389..2d1b9acccaea 100644
--- a/devel/libqcow/Makefile
+++ b/devel/libqcow/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libqcow
DISTVERSION= alpha-20141201
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://github.com/libyal/libqcow/releases/download/${PORTVERSION:E}/ \
LOCAL/antoine
@@ -18,6 +19,8 @@ USES= fuse gettext iconv libtool pathfix pkgconfig python:2
USE_OPENSSL= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
PORTDOCS= AUTHORS ChangeLog
diff --git a/devel/libsmraw/Makefile b/devel/libsmraw/Makefile
index 66b06f60c5e8..3d9284b5af55 100644
--- a/devel/libsmraw/Makefile
+++ b/devel/libsmraw/Makefile
@@ -3,9 +3,9 @@
PORTNAME= libsmraw
DISTVERSION= alpha-20141026
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= https://googledrive.com/host/0B3fBvzttpiiSRml2cndCelp2R3M/ \
- https://github.com/libyal/libsmraw/releases/download/${PORTVERSION:E}/ \
+MASTER_SITES= https://github.com/libyal/libsmraw/releases/download/${PORTVERSION:E}/ \
LOCAL/antoine
MAINTAINER= antoine@FreeBSD.org
@@ -19,6 +19,8 @@ USES= fuse gettext iconv libtool pathfix pkgconfig python:2
USE_OPENSSL= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
PORTDOCS= AUTHORS ChangeLog