aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-05-08 06:09:03 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-05-08 06:09:03 +0000
commitff996e3290b7ab3151081d01804af3332348c2c9 (patch)
tree201390a424bfd7471fe1731b369afe0398e0c7f0 /devel
parentc56ddf9af14ae2f63475816de7f36a561e29b951 (diff)
As previously announced, remove these broken or obsolete ports.
Notes
Notes: svn path=/head/; revision=108672
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile3
-rw-r--r--devel/as80/Makefile31
-rw-r--r--devel/as80/distinfo2
-rw-r--r--devel/as80/files/patch-README14
-rw-r--r--devel/as80/files/patch-src_as80.c105
-rw-r--r--devel/as80/files/patch-src_aux.c13
-rw-r--r--devel/as80/files/patch-src_symtbl.c13
-rw-r--r--devel/as80/pkg-descr4
-rw-r--r--devel/as80/pkg-plist4
-rw-r--r--devel/qt-designer/Makefile61
-rw-r--r--devel/qt-designer/pkg-descr4
-rw-r--r--devel/qt-designer/pkg-plist164
-rw-r--r--devel/uisp/Makefile22
-rw-r--r--devel/uisp/distinfo2
-rw-r--r--devel/uisp/files/patch-DAPA.C13
-rw-r--r--devel/uisp/files/patch-Makefile.in14
-rw-r--r--devel/uisp/pkg-descr10
-rw-r--r--devel/uisp/pkg-plist2
18 files changed, 0 insertions, 481 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2266e9719510..063a5838d786 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -49,7 +49,6 @@
SUBDIR += arm-rtems-gdb
SUBDIR += arm-rtems-objc
SUBDIR += as31
- SUBDIR += as80
SUBDIR += asis
SUBDIR += asl
SUBDIR += asmutils
@@ -1076,7 +1075,6 @@
SUBDIR += qextmdi
SUBDIR += qmake
SUBDIR += qssl
- SUBDIR += qt-designer
SUBDIR += qtez
SUBDIR += qtk
SUBDIR += ragel
@@ -1236,7 +1234,6 @@
SUBDIR += tvision
SUBDIR += uclmmbase
SUBDIR += ucpp
- SUBDIR += uisp
SUBDIR += umbrello
SUBDIR += upnp
SUBDIR += ups-debug
diff --git a/devel/as80/Makefile b/devel/as80/Makefile
deleted file mode 100644
index 861d76de1bde..000000000000
--- a/devel/as80/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# New ports collection makefile for: as80
-# Date created: 02 January 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= as80
-PORTVERSION= 0.8
-CATEGORIES= devel
-MASTER_SITES= # dead
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A lightweight 8080/8085 assembler
-
-DEPRECATED= "mastersite disappeared\; alternatives are available, such as devel/asl"
-EXPIRATION_DATE= "April 22, 2004"
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-BUILD_WRKSRC= ${WRKSRC}/src
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-ALL_TARGET= as80
-
-do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/as80 ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/as80
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/as80
-.endif
-
-.include <bsd.port.mk>
diff --git a/devel/as80/distinfo b/devel/as80/distinfo
deleted file mode 100644
index bb3204fb72f3..000000000000
--- a/devel/as80/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (as80-0.8.tar.gz) = 6b002716ce22df6410d54edc926dfb00
-SIZE (as80-0.8.tar.gz) = 20480
diff --git a/devel/as80/files/patch-README b/devel/as80/files/patch-README
deleted file mode 100644
index 0089c4e84b9f..000000000000
--- a/devel/as80/files/patch-README
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- README.orig Sat Dec 1 14:17:47 2001
-+++ README Sat Dec 1 14:18:09 2001
-@@ -18,7 +18,7 @@
- This is version 0.8
-
-
--usage: asm80 infile [outfile] [-l listfile] [-s symfile]
-+usage: as80 infile [outfile] [-l listfile] [-s symfile]
-
- infile is the assembler's input
- outfile is the binary output file
diff --git a/devel/as80/files/patch-src_as80.c b/devel/as80/files/patch-src_as80.c
deleted file mode 100644
index b830be9ee7db..000000000000
--- a/devel/as80/files/patch-src_as80.c
+++ /dev/null
@@ -1,105 +0,0 @@
-
-$FreeBSD$
-
---- src/as80.c.orig Fri Nov 30 02:34:26 2001
-+++ src/as80.c Fri Nov 30 02:36:13 2001
-@@ -26,11 +26,6 @@
- #include <stdlib.h>
- #include <ctype.h>
- #include <errno.h>
--
--#if SYSTEM == GNU
--#include <getopt.h>
--#endif
--
- #include "types.h"
- #include "symtbl.h"
- #include "as80.h"
-@@ -218,8 +213,6 @@
- int
- init (int argc, char **argv)
- {
--/* on a GNU system we can use getopt to parse command line options */
--#if SYSTEM == GNU
- int index, c;
-
- /* no proper command line input */
-@@ -294,78 +287,6 @@
- break;
- }
- }
--
--#else
-- /* otherwise we have to do it manually */
-- int arg = 1;
--
-- puts ("non-GNU system\n");
--
-- /* no proper command line input */
-- if (argc < 2)
-- {
-- fprintf (stderr,
-- "usage: %s infile [-o outfile] [-l listfile] [-s symfile]\n",
-- argv[0]);
-- return ERR_INIT;
-- }
--
-- /* parse */
-- while (arg < argc)
-- {
-- if (argv[arg][0] != '-')
-- {
-- iname = argv[arg];
-- if ((IN = fopen (iname, "r")) == NULL)
-- {
-- perror ("couldn't open input file");
-- return ERR_INIT;
-- }
-- arg = 1;
-- break;
-- }
-- arg++;
-- }
--
-- while ((arg < argc) && (argv[arg][0] == '-'))
-- {
-- if (strcmp (argv[arg], "-o"))
-- {
-- if ((OUT = fopen (argv[++arg], "wb")) == NULL)
-- {
-- perror ("couldn't topen output file");
-- return ERR_INIT;
-- }
-- doout = 1;
-- }
-- else if (strcmp (argv[arg], "-l"))
-- {
-- if ((LST = fopen (optarg, "w")) == NULL)
-- {
-- perror ("couldn't open list file");
-- return ERR_INIT;
-- }
-- dolist = 1;
-- }
-- else if (strcmp (argv[arg], "-s"))
-- {
-- if ((SYM = fopen (optarg, "w")) == NULL)
-- {
-- perror ("couldn't open symbol file");
-- return ERR_INIT;
-- }
-- dosym = 1;
-- }
-- else
-- {
-- fprintf (stderr, "unknown option %s\n", argv[arg]);
-- return ERR_INIT;
-- }
--
-- arg++;
-- }
--
--#endif
-
- /* open default outputfile */
- if (doout == 0)
diff --git a/devel/as80/files/patch-src_aux.c b/devel/as80/files/patch-src_aux.c
deleted file mode 100644
index e7525997bdb6..000000000000
--- a/devel/as80/files/patch-src_aux.c
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- src/aux.c.orig Fri Nov 30 02:36:50 2001
-+++ src/aux.c Fri Nov 30 02:36:51 2001
-@@ -22,6 +22,7 @@
-
- #include <stdlib.h>
- #include <ctype.h>
-+#include <string.h>
- #include "aux.h"
-
-
diff --git a/devel/as80/files/patch-src_symtbl.c b/devel/as80/files/patch-src_symtbl.c
deleted file mode 100644
index 0282de852473..000000000000
--- a/devel/as80/files/patch-src_symtbl.c
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- src/symtbl.c.orig Fri Nov 30 02:35:55 2001
-+++ src/symtbl.c Fri Nov 30 02:36:08 2001
-@@ -22,6 +22,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include "types.h"
- #include "symtbl.h"
-
diff --git a/devel/as80/pkg-descr b/devel/as80/pkg-descr
deleted file mode 100644
index 0e8494baaf46..000000000000
--- a/devel/as80/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-As80 is a table-driven assembler for the 8080/8085 line of
-microprocessors from Intel. It uses cpp for macros and includes.
-
-WWW: http://www.tstrathmann.de/as80.html
diff --git a/devel/as80/pkg-plist b/devel/as80/pkg-plist
deleted file mode 100644
index b1e01f59e6cd..000000000000
--- a/devel/as80/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@comment $FreeBSD$
-bin/as80
-share/doc/as80/README
-@dirrm share/doc/as80
diff --git a/devel/qt-designer/Makefile b/devel/qt-designer/Makefile
deleted file mode 100644
index 6549967ecaa4..000000000000
--- a/devel/qt-designer/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# New ports collection makefile for: Qt Designer
-# Date created: Sat Feb 3 23:04:41 EST 2001
-# Whom: will
-#
-# $FreeBSD$
-#
-
-PORTNAME= qt-designer
-CATEGORIES= devel
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GUI C++ IDE based on QT
-
-LIB_DEPENDS+= qt2.4:${PORTSDIR}/x11-toolkits/qt23
-
-MASTERDIR= ${.CURDIR}/../../x11-toolkits/qt23
-
-CONFLICTS= qt-3.*
-BROKEN= "fails to install"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-21
-
-WRKSRC= ${WRKDIR}/qt-${PORTVERSION}
-PATCH_WRKSRC= ${WRKSRC}
-PKGDIR= ${.CURDIR}
-MAKE_ENV= QTDIR=${PREFIX} LD_LIBRARY_PATH=${PREFIX}/lib PREFIX=${PREFIX}
-ALL_TARGET= sub-tools
-USE_REINPLACE= yes
-
-post-patch:
- ${REINPLACE_CMD} -e "s@-fno-exceptions@& -I${X11BASE}/include/qt2@g" ${CONFIG}
-
-do-build:
- (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-
-qt-pre-configure:
- ${REINPLACE_CMD} -e 's@\(DESTDIR = \)\$$(QTDIR)/bin@\1../../../bin@' \
- ${WRKSRC}/tools/designer/designer/Makefile.in
- ${REINPLACE_CMD} -e 's@\(sub-tools: \)sub-src @\1@' ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e 's@\$$\(MAKE\) util@@; s@\$$\(MAKE\) uic@@; \
- s@util \\@designer@g; s@uic \\@@g; \
- s@'"`printf '\t\t'`"'designer@@g' ${WRKSRC}/tools/designer/Makefile.in
- ${REINPLACE_CMD} -e 's@getenv( "QTDIR" )@QT_PREFIX@g; \
- s@/tools/designer/templates@/share/qt2/designer/templates@g' \
- ${WRKSRC}/tools/designer/designer/newformimpl.cpp
-
-.include "${MASTERDIR}/Makefile"
-
-do-install:
- ${MKDIR} ${PREFIX}/share/qt2/designer/templates \
- ${PREFIX}/share/doc/qt2/html/designer/arrows \
- ${PREFIX}/share/doc/qt2/html/designer/figures
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/designer ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/tools/designer/templates/* \
- ${PREFIX}/share/qt2/designer/templates
- ${INSTALL_DATA} ${WRKSRC}/doc/html/designer/*.html \
- ${PREFIX}/share/doc/qt2/html/designer
-.for IMGDIR in arrows figures
- ${INSTALL_DATA} ${WRKSRC}/doc/html/designer/${IMGDIR}/*.png \
- ${PREFIX}/share/doc/qt2/html/designer/${IMGDIR}
-.endfor
diff --git a/devel/qt-designer/pkg-descr b/devel/qt-designer/pkg-descr
deleted file mode 100644
index 74664b302c3d..000000000000
--- a/devel/qt-designer/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Qt Designer is a GUI IDE based on Qt 2.x made by
-the trolltech people.
-
-WWW: http://www.trolltech.com/products/qt/designer/
diff --git a/devel/qt-designer/pkg-plist b/devel/qt-designer/pkg-plist
deleted file mode 100644
index c4612f2176b3..000000000000
--- a/devel/qt-designer/pkg-plist
+++ /dev/null
@@ -1,164 +0,0 @@
-share/qt2/designer/templates/Tab-Dialog.ui
-share/qt2/designer/templates/Dialog_with_Buttons_(Right).ui
-share/qt2/designer/templates/Dialog_with_Buttons_(Bottom).ui
-share/qt2/designer/templates/Configuration_Dialog.ui
-share/doc/qt2/html/designer/preface.html
-share/doc/qt2/html/designer/part2index.html
-share/doc/qt2/html/designer/part1index.html
-share/doc/qt2/html/designer/figures/whatsthis.png
-share/doc/qt2/html/designer/figures/vlayout.png
-share/doc/qt2/html/designer/figures/undo.png
-share/doc/qt2/html/designer/figures/topicchooser.png
-share/doc/qt2/html/designer/figures/toolbutton.png
-share/doc/qt2/html/designer/figures/title.png
-share/doc/qt2/html/designer/figures/textview.png
-share/doc/qt2/html/designer/figures/textbrowser.png
-share/doc/qt2/html/designer/figures/testmode.png
-share/doc/qt2/html/designer/figures/tabwidget.png
-share/doc/qt2/html/designer/figures/taborderform.png
-share/doc/qt2/html/designer/figures/startup.png
-share/doc/qt2/html/designer/figures/spinbox.png
-share/doc/qt2/html/designer/figures/spacer.png
-share/doc/qt2/html/designer/figures/slots.png
-share/doc/qt2/html/designer/figures/slider.png
-share/doc/qt2/html/designer/figures/right.png
-share/doc/qt2/html/designer/figures/redo.png
-share/doc/qt2/html/designer/figures/radiobutton.png
-share/doc/qt2/html/designer/figures/qtlogo.png
-share/doc/qt2/html/designer/figures/pushbutton.png
-share/doc/qt2/html/designer/figures/progress.png
-share/doc/qt2/html/designer/figures/print.png
-share/doc/qt2/html/designer/figures/preferences.png
-share/doc/qt2/html/designer/figures/pointer.png
-share/doc/qt2/html/designer/figures/pizza1screenshot.png
-share/doc/qt2/html/designer/figures/pixlabel.png
-share/doc/qt2/html/designer/figures/paletteeditor.png
-share/doc/qt2/html/designer/figures/ordertool.png
-share/doc/qt2/html/designer/figures/onecheckbox.png
-share/doc/qt2/html/designer/figures/objecthierarchy.png
-share/doc/qt2/html/designer/figures/newformdialog.png
-share/doc/qt2/html/designer/figures/newform.png
-share/doc/qt2/html/designer/figures/multilineedit.png
-share/doc/qt2/html/designer/figures/load.png
-share/doc/qt2/html/designer/figures/listview.png
-share/doc/qt2/html/designer/figures/listbox.png
-share/doc/qt2/html/designer/figures/lineedit.png
-share/doc/qt2/html/designer/figures/line.png
-share/doc/qt2/html/designer/figures/left.png
-share/doc/qt2/html/designer/figures/lcdnumber.png
-share/doc/qt2/html/designer/figures/layouttutstep9.png
-share/doc/qt2/html/designer/figures/layouttutstep7.png
-share/doc/qt2/html/designer/figures/layouttutstep6.png
-share/doc/qt2/html/designer/figures/layouttutstep5.png
-share/doc/qt2/html/designer/figures/layouttutstep4.png
-share/doc/qt2/html/designer/figures/layouttutstep3.png
-share/doc/qt2/html/designer/figures/layouttutstep2.png
-share/doc/qt2/html/designer/figures/layouttutstep11.png
-share/doc/qt2/html/designer/figures/layouttutstep10.png
-share/doc/qt2/html/designer/figures/layouttutstep1.png
-share/doc/qt2/html/designer/figures/layout.png
-share/doc/qt2/html/designer/figures/label.png
-share/doc/qt2/html/designer/figures/image.png
-share/doc/qt2/html/designer/figures/iconview.png
-share/doc/qt2/html/designer/figures/home.png
-share/doc/qt2/html/designer/figures/helpdialog.png
-share/doc/qt2/html/designer/figures/help.png
-share/doc/qt2/html/designer/figures/groupbox.png
-share/doc/qt2/html/designer/figures/frame.png
-share/doc/qt2/html/designer/figures/fourcheckboxes.png
-share/doc/qt2/html/designer/figures/formsettings.png
-share/doc/qt2/html/designer/figures/form.png
-share/doc/qt2/html/designer/figures/firstdialog.png
-share/doc/qt2/html/designer/figures/filesave.png
-share/doc/qt2/html/designer/figures/filenew.png
-share/doc/qt2/html/designer/figures/f001.png
-share/doc/qt2/html/designer/figures/emptydialog.png
-share/doc/qt2/html/designer/figures/editslots.png
-share/doc/qt2/html/designer/figures/editraise.png
-share/doc/qt2/html/designer/figures/editpaste.png
-share/doc/qt2/html/designer/figures/editmultiline.png
-share/doc/qt2/html/designer/figures/editlower.png
-share/doc/qt2/html/designer/figures/editlistview.png
-share/doc/qt2/html/designer/figures/editlistbox.png
-share/doc/qt2/html/designer/figures/editiconview.png
-share/doc/qt2/html/designer/figures/edithlayout.png
-share/doc/qt2/html/designer/figures/editgrid.png
-share/doc/qt2/html/designer/figures/editdelete.png
-share/doc/qt2/html/designer/figures/editcut.png
-share/doc/qt2/html/designer/figures/editcustomwidgets.png
-share/doc/qt2/html/designer/figures/editcopy.png
-share/doc/qt2/html/designer/figures/customwidgets.png
-share/doc/qt2/html/designer/figures/customwidget.png
-share/doc/qt2/html/designer/figures/connecttool.png
-share/doc/qt2/html/designer/figures/connectionviewer.png
-share/doc/qt2/html/designer/figures/connections.png
-share/doc/qt2/html/designer/figures/connectionedit.png
-share/doc/qt2/html/designer/figures/combobox.png
-share/doc/qt2/html/designer/figures/checkbox.png
-share/doc/qt2/html/designer/figures/buttongroupovercheckboxes.png
-share/doc/qt2/html/designer/figures/buttongroup.png
-share/doc/qt2/html/designer/figures/breaklayout.png
-share/doc/qt2/html/designer/figures/adjustsize.png
-share/doc/qt2/html/designer/figures/aboutdialog.png
-share/doc/qt2/html/designer/feedback.html
-share/doc/qt2/html/designer/colophon.html
-share/doc/qt2/html/designer/chap9_6.html
-share/doc/qt2/html/designer/chap9_5.html
-share/doc/qt2/html/designer/chap9_4.html
-share/doc/qt2/html/designer/chap9_3.html
-share/doc/qt2/html/designer/chap9_2.html
-share/doc/qt2/html/designer/chap9_1.html
-share/doc/qt2/html/designer/chap8_1.html
-share/doc/qt2/html/designer/chap7_9.html
-share/doc/qt2/html/designer/chap7_8.html
-share/doc/qt2/html/designer/chap7_7.html
-share/doc/qt2/html/designer/chap7_6.html
-share/doc/qt2/html/designer/chap7_5.html
-share/doc/qt2/html/designer/chap7_4.html
-share/doc/qt2/html/designer/chap7_3.html
-share/doc/qt2/html/designer/chap7_2.html
-share/doc/qt2/html/designer/chap7_16.html
-share/doc/qt2/html/designer/chap7_15.html
-share/doc/qt2/html/designer/chap7_14.html
-share/doc/qt2/html/designer/chap7_13.html
-share/doc/qt2/html/designer/chap7_12.html
-share/doc/qt2/html/designer/chap7_11.html
-share/doc/qt2/html/designer/chap7_10.html
-share/doc/qt2/html/designer/chap7_1.html
-share/doc/qt2/html/designer/chap6_7.html
-share/doc/qt2/html/designer/chap6_6.html
-share/doc/qt2/html/designer/chap6_5.html
-share/doc/qt2/html/designer/chap6_4.html
-share/doc/qt2/html/designer/chap6_3.html
-share/doc/qt2/html/designer/chap6_2.html
-share/doc/qt2/html/designer/chap6_1.html
-share/doc/qt2/html/designer/chap5_6.html
-share/doc/qt2/html/designer/chap5_5.html
-share/doc/qt2/html/designer/chap5_4.html
-share/doc/qt2/html/designer/chap5_3.html
-share/doc/qt2/html/designer/chap5_2.html
-share/doc/qt2/html/designer/chap5_1.html
-share/doc/qt2/html/designer/chap4_2.html
-share/doc/qt2/html/designer/chap4_1.html
-share/doc/qt2/html/designer/chap3_4.html
-share/doc/qt2/html/designer/chap3_3.html
-share/doc/qt2/html/designer/chap3_2.html
-share/doc/qt2/html/designer/chap3_1.html
-share/doc/qt2/html/designer/chap2_4.html
-share/doc/qt2/html/designer/chap2_3.html
-share/doc/qt2/html/designer/chap2_2.html
-share/doc/qt2/html/designer/chap2_1.html
-share/doc/qt2/html/designer/chap1_1.html
-share/doc/qt2/html/designer/chap10_1.html
-share/doc/qt2/html/designer/book1.html
-share/doc/qt2/html/designer/arrows/up.png
-share/doc/qt2/html/designer/arrows/right.png
-share/doc/qt2/html/designer/arrows/left.png
-share/doc/qt2/html/designer/arrows/home.png
-bin/designer
-@dirrm share/qt2/designer/templates
-@dirrm share/qt2/designer
-@dirrm share/qt2
-@dirrm share/doc/qt2/html/designer/figures
-@dirrm share/doc/qt2/html/designer/arrows
-@dirrm share/doc/qt2/html/designer
diff --git a/devel/uisp/Makefile b/devel/uisp/Makefile
deleted file mode 100644
index edefaae7d31c..000000000000
--- a/devel/uisp/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# New ports collection makefile for: uisp
-# Date created: 17 Feb 2001
-# Whom: Bruno Schwander<bruno@tinkerbox.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= uisp
-PORTVERSION= 20020626
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A versatile programmer for atmel AVR microcontrollers
-
-DEPRECATED= "distfile unfetchable\; superceded by devel/avrdude"
-EXPIRATION_DATE= "April 17, 2004"
-
-GNU_CONFIGURE= yes
-
-.include <bsd.port.mk>
diff --git a/devel/uisp/distinfo b/devel/uisp/distinfo
deleted file mode 100644
index 3442d924abc6..000000000000
--- a/devel/uisp/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (uisp-20020626.tar.gz) = aeb78302d0127d692c03847a81174eca
-SIZE (uisp-20020626.tar.gz) = 111834
diff --git a/devel/uisp/files/patch-DAPA.C b/devel/uisp/files/patch-DAPA.C
deleted file mode 100644
index 19c37069e20e..000000000000
--- a/devel/uisp/files/patch-DAPA.C
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- src/DAPA.C.orig Thu Jun 13 15:17:24 2002
-+++ src/DAPA.C Thu Nov 21 20:37:08 2002
-@@ -72,6 +72,7 @@
-
- #elif defined(__FreeBSD__) && defined(__i386__)
-
-+#include <sys/types.h>
- #include <sys/fcntl.h>
- #include <machine/cpufunc.h>
- #include <machine/sysarch.h>
diff --git a/devel/uisp/files/patch-Makefile.in b/devel/uisp/files/patch-Makefile.in
deleted file mode 100644
index 134af40b217e..000000000000
--- a/devel/uisp/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Thu Nov 21 20:34:28 2002
-+++ Makefile.in Thu Nov 21 20:35:07 2002
-@@ -327,7 +327,7 @@
- install-exec-am:
- install-exec: install-exec-recursive
-
--install-data-am: install-data-local
-+install-data-am: # install-data-local
- install-data: install-data-recursive
-
- install-am: all-am
diff --git a/devel/uisp/pkg-descr b/devel/uisp/pkg-descr
deleted file mode 100644
index 0318f8cd7ad1..000000000000
--- a/devel/uisp/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-This is aport of uisp, a tool to program an atmel AVR microcontroller
-through your parallel or serial port. Several programming hardware are
-supported, the only one I have tested and the simplest one (no component)
-is the in-circuit parallel programmer. Schematics are available online.
-
-WWW: http://savannah.nongnu.org/projects/uisp
-
-- Bruno
-
-bruno@tinkerbox.org
diff --git a/devel/uisp/pkg-plist b/devel/uisp/pkg-plist
deleted file mode 100644
index 10e9ba1049ae..000000000000
--- a/devel/uisp/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-@comment $FreeBSD$
-bin/uisp