aboutsummaryrefslogtreecommitdiff
path: root/dns/adns
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-10-25 12:09:30 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-10-25 12:09:30 +0000
commit0632a010088f0e66bfe05b75196fd7a9121669ab (patch)
tree84af6974ca2bf47b7b99021298a3e0e20832706e /dns/adns
parent7d1aef3edc46de3d0105f2b2d4b38f04d868dcdb (diff)
downloadports-0632a010088f0e66bfe05b75196fd7a9121669ab.tar.gz
ports-0632a010088f0e66bfe05b75196fd7a9121669ab.zip
dns/adns: 1.4 -> 1.5.0~rc0
New features: * Support for queries about IPv6 data in all applicable adns query types (including AAAA, PTR, and adns_r_addr queries). (Thanks very much to Mark Wooding.) * Support for transport over IPv6. (Thanks to Mark Wooding again.) * adns_addr2text and adns_text2addr: Convenient functions for converting between addresses and address literals. Bugfixes: * Fix a crashing bug in adnslogres. (Debian#392102.) * Do all checks of checked PTR owner name before actually sending the query, and reject IPv4 PTR owner names whose labels have leading zero digits or values >255. Build system fixes and improvements: * `make clean' removes the pipes. * Work around bugs in make (Debian #4073, #756123) affecting regress. * Do not include Makefile and src/config.h in distribution tarball. Regression test debugging improvements: * Provide gdbwrap convenience script. * Honour ADNS_TEST_DEBUG env. var. (Mark Wooding.) Submitted by: pi (maintainer)
Notes
Notes: svn path=/head/; revision=371480
Diffstat (limited to 'dns/adns')
-rw-r--r--dns/adns/Makefile14
-rw-r--r--dns/adns/distinfo4
-rw-r--r--dns/adns/files/patch-regress-Makefile.in11
-rw-r--r--dns/adns/pkg-plist2
4 files changed, 21 insertions, 10 deletions
diff --git a/dns/adns/Makefile b/dns/adns/Makefile
index d157370a5659..1e9d3712c595 100644
--- a/dns/adns/Makefile
+++ b/dns/adns/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= adns
-PORTVERSION= 1.4
-PORTREVISION= 2
+PORTVERSION= 1.5
CATEGORIES= dns
MASTER_SITES= http://www.chiark.greenend.org.uk/~ian/adns/ftp/
+EXTRACT_SUFX= .0~rc0.tar.gz
MAINTAINER= pi@FreeBSD.org
COMMENT= Easy to use asynchronous-capable DNS client library and utilities
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.0~rc0
+
USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -21,11 +23,11 @@ BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4
CFLAGS+= -Ds6_addr16=__u6_addr.__u6_addr16
CFLAGS+= -Ds6_addr32=__u6_addr.__u6_addr32
MAKE_FLAGS+= M4=gm4
-PATCH_SITES+= https://people.debian.org/~lucab/deb/adns/:ipv6patch
-PATCHFILES+= adns-ipv6.patch:ipv6patch
-PATCH_DIST_STRIP+= -p1
+#PATCH_SITES+= https://people.debian.org/~lucab/deb/adns/:ipv6patch
+#PATCHFILES+= adns-ipv6.patch:ipv6patch
+#PATCH_DIST_STRIP+= -p1
-DOCS= COPYING GPL-vs-LGPL INSTALL LICENCE.WAIVERS README \
+DOCS= COPYING GPL-vs-LGPL INSTALL README \
README.html TODO changelog
TOSTRIP= bin/adnsheloex \
diff --git a/dns/adns/distinfo b/dns/adns/distinfo
index 820b5c5a7d73..f974075b2b4f 100644
--- a/dns/adns/distinfo
+++ b/dns/adns/distinfo
@@ -1,4 +1,4 @@
-SHA256 (adns-1.4.tar.gz) = 717b92a39117a5d8b04ea7c652c630659c6eecb35211129a8cee95e6524ca9fe
-SIZE (adns-1.4.tar.gz) = 252668
+SHA256 (adns-1.5.0~rc0.tar.gz) = ae9459c778d21b6cdb8cd98731ff103c264b47df4bd44e38573a697cb0893b4a
+SIZE (adns-1.5.0~rc0.tar.gz) = 345530
SHA256 (adns-ipv6.patch) = 84adcc350ee9a3144e0b48fb12ad8f7e8f028a5316b7948e698acaf57afae2e4
SIZE (adns-ipv6.patch) = 88709
diff --git a/dns/adns/files/patch-regress-Makefile.in b/dns/adns/files/patch-regress-Makefile.in
new file mode 100644
index 000000000000..bb6c0defb518
--- /dev/null
+++ b/dns/adns/files/patch-regress-Makefile.in
@@ -0,0 +1,11 @@
+--- regress/Makefile.in.orig 2014-10-25 13:43:05.000000000 +0200
++++ regress/Makefile.in 2014-10-25 13:43:08.000000000 +0200
+@@ -25,7 +25,7 @@
+
+ PROGS_SYSDEP= @PROGS_HAVE_TSEARCH@
+
+-CLIENTS= adnstest adnshost adnslogres $(PROGS_SYSDEP)
++CLIENTS= adnstest adnslogres $(PROGS_SYSDEP)
+ AUTOCHDRS= harness.h hsyscalls.h hredirect.h
+ AUTOCSRCS= hrecord.c hplayback.c hcommon.c
+ include ../settings.make
diff --git a/dns/adns/pkg-plist b/dns/adns/pkg-plist
index 3c100538098d..7394d52fd5b6 100644
--- a/dns/adns/pkg-plist
+++ b/dns/adns/pkg-plist
@@ -9,9 +9,7 @@ lib/libadns.so.%%LIBVERSION%%
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/GPL-vs-LGPL
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENCE.WAIVERS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.html
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/changelog
-%%PORTDOCS%%@dirrm %%DOCSDIR%%