aboutsummaryrefslogtreecommitdiff
path: root/dns/adsuck
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-05 16:53:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-05 16:53:09 +0000
commitd140115591600c520e3e358c96a932b0ca84db33 (patch)
tree0be691d6bda55c24c189deb814d1363bb12eaf21 /dns/adsuck
parent35902762f20c26f34d1c851b8fb42d0bfcf603dc (diff)
downloadports-d140115591600c520e3e358c96a932b0ca84db33.tar.gz
ports-d140115591600c520e3e358c96a932b0ca84db33.zip
Convert to use libevent2
Notes
Notes: svn path=/head/; revision=347122
Diffstat (limited to 'dns/adsuck')
-rw-r--r--dns/adsuck/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/dns/adsuck/Makefile b/dns/adsuck/Makefile
index 106588ad3be0..ddefcd6d15ef 100644
--- a/dns/adsuck/Makefile
+++ b/dns/adsuck/Makefile
@@ -3,7 +3,7 @@
PORTNAME= adsuck
PORTVERSION= 2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://opensource.conformal.com/snapshots/adsuck/ \
http://philpep.org/pub/
@@ -12,10 +12,14 @@ EXTRACT_SUFX= .tgz
MAINTAINER= phil@philpep.org
COMMENT= DNS relay for ad blocking
-LICENSE= BSD
+LICENSE= ISCL
-LIB_DEPENDS+= libevent-1.4.so:${PORTSDIR}/devel/libevent \
- ldns:${PORTSDIR}/dns/ldns
+LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2 \
+ libldns.so:${PORTSDIR}/dns/ldns
+
+CFLAGS+= -I${LOCALBASE}/include/event2/compat \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib/event2
USE_RC_SUBR= adsuck
@@ -26,6 +30,9 @@ SUB_FILES+= pkg-message
OPTIONS_DEFINE= EXAMPLES
+post-patch:
+ @${REINPLACE_CMD} -e "s/-levent/-levent-2.0/g" ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/adsuck ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8.gz ${STAGEDIR}${MANPREFIX}/man/man8