aboutsummaryrefslogtreecommitdiff
path: root/dns/autotrust/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-18 14:59:23 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-18 14:59:23 +0000
commit3e46e4f264728cd5a25e34c044a02b260bdf3af6 (patch)
tree2c580acf6831f27130c7e76d7890a6e96d2006f7 /dns/autotrust/Makefile
parenteff58e73b2e690c8b2bdf42b79a2ca6c1ce2ee36 (diff)
downloadports-3e46e4f264728cd5a25e34c044a02b260bdf3af6.tar.gz
ports-3e46e4f264728cd5a25e34c044a02b260bdf3af6.zip
Notes
Diffstat (limited to 'dns/autotrust/Makefile')
-rw-r--r--dns/autotrust/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/dns/autotrust/Makefile b/dns/autotrust/Makefile
index babff839e89a..3180e1caa768 100644
--- a/dns/autotrust/Makefile
+++ b/dns/autotrust/Makefile
@@ -10,20 +10,17 @@ MASTER_SITES= http://www.nlnetlabs.nl/downloads/autotrust/
MAINTAINER= jaap@NLnetLabs.nl
COMMENT= A tool to automatically update DNSSEC trust anchors
-LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns \
- unbound:${PORTSDIR}/dns/unbound
+LIB_DEPENDS+= libldns.so:${PORTSDIR}/dns/ldns \
+ libunbound.so:${PORTSDIR}/dns/unbound
GNU_CONFIGURE= yes
CFLAGS= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-MAN8= autotrust.8
-
-PLIST_FILES= sbin/autotrust \
+PLIST_FILES= sbin/autotrust man/man8/autotrust.8.gz \
etc/autotrust/autotrust.conf.sample
PLIST_DIRS= etc/autotrust
-NO_STAGE= yes
do-patch:
${REINPLACE_CMD} \
'45s!=!\?=!; \
@@ -31,9 +28,9 @@ do-patch:
${WRKSRC}/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
- ${MKDIR} ${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${ETCDIR}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${STAGEDIR}${ETCDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
.include <bsd.port.mk>