aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-02-22 15:33:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-02-22 15:33:54 +0000
commit7ac64f74669c22f4a45cabc1ee58823d06407ff9 (patch)
treefb3e9076354378565dfd52773d816a60d3f7cf34 /dns/bind9-devel
parentfedda1ccc7910933420cfd8b365223440ee558c1 (diff)
downloadports-7ac64f74669c22f4a45cabc1ee58823d06407ff9.tar.gz
ports-7ac64f74669c22f4a45cabc1ee58823d06407ff9.zip
Update to latest commit:
Notes
Notes: svn path=/head/; revision=566304
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/pkg-plist15
4 files changed, 19 insertions, 20 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 0f07b11f896a..81e9006081b5 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -50,13 +50,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.9a0.2021.02.14
+ISCVERSION= 9.17.10a0.2021.02.19
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 8c1df63312a02d2352312b07f292d8e84672fec2
+GL_COMMIT= bb124d6056e5e8bc2a960ea9de914744803378bc
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 5095107e2e45..1f371d6f7adb 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613380526
-SHA256 (isc-projects-bind9-8c1df63312a02d2352312b07f292d8e84672fec2_GL0.tar.gz) = d405e2bea2569222646260b87cb1e7661a572c356342fc44fa52acca823f2abc
-SIZE (isc-projects-bind9-8c1df63312a02d2352312b07f292d8e84672fec2_GL0.tar.gz) = 6393007
+TIMESTAMP = 1614000873
+SHA256 (isc-projects-bind9-bb124d6056e5e8bc2a960ea9de914744803378bc_GL0.tar.gz) = 6f08411e601c56847f203d3b78d2239801c512a2ed6165cc980a975b0342b0c5
+SIZE (isc-projects-bind9-bb124d6056e5e8bc2a960ea9de914744803378bc_GL0.tar.gz) = 6396003
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index e795c0f65aac..ae2e6d65075d 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2021-02-14 23:02:44 UTC
+--- bin/named/config.c.orig 2021-02-19 12:30:50 UTC
+++ bin/named/config.c
@@ -181,6 +181,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2021-02-14 23:02:44 UTC
+--- bin/named/server.c.orig 2021-02-19 12:30:50 UTC
+++ bin/named/server.c
-@@ -4441,6 +4441,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4445,6 +4445,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2021-02-14 23:02:44 UTC
+--- lib/dns/include/dns/view.h.orig 2021-02-19 12:30:50 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2021-02-14 23:02:44 UTC
+--- lib/dns/resolver.c.orig 2021-02-19 12:30:50 UTC
+++ lib/dns/resolver.c
@@ -6388,6 +6388,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2021-02-14 23:02:44 UTC
+--- lib/isccfg/namedconf.c.orig 2021-02-19 12:30:50 UTC
+++ lib/isccfg/namedconf.c
-@@ -2007,6 +2007,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2024,6 +2024,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", NULL, CFG_CLAUSEFLAG_ANCIENT },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 52d583791b1a..fbe7807f5d2d 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -193,7 +193,6 @@ include/isc/quota.h
include/isc/radix.h
include/isc/random.h
include/isc/ratelimiter.h
-include/isc/readline.h
include/isc/refcount.h
include/isc/regex.h
include/isc/region.h
@@ -266,19 +265,19 @@ include/pk11/site.h
include/pkcs11/pkcs11.h
lib/bind/filter-aaaa.so
lib/libbind9.so
-lib/libbind9-9.17.9.so
+lib/libbind9-9.17.10.so
lib/libdns.so
-lib/libdns-9.17.9.so
+lib/libdns-9.17.10.so
lib/libirs.so
-lib/libirs-9.17.9.so
+lib/libirs-9.17.10.so
lib/libisc.so
-lib/libisc-9.17.9.so
+lib/libisc-9.17.10.so
lib/libisccc.so
-lib/libisccc-9.17.9.so
+lib/libisccc-9.17.10.so
lib/libisccfg.so
-lib/libisccfg-9.17.9.so
+lib/libisccfg-9.17.10.so
lib/libns.so
-lib/libns-9.17.9.so
+lib/libns-9.17.10.so
@comment lib/named/filter-aaaa.so
@comment man/man1/arpaname.1.gz
@comment man/man1/delv.1.gz