aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-08-24 14:30:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-08-24 14:30:07 +0000
commit840a4c40b54675c1401fce8a05ee1381874c25df (patch)
tree41d02065ea0bb4fb84aa383ab3a1ff862a5dee0c /dns/bind9-devel
parent12943087bfcde247ecad6e3cd78aafd6cd5a2aab (diff)
downloadports-840a4c40b54675c1401fce8a05ee1381874c25df.tar.gz
ports-840a4c40b54675c1401fce8a05ee1381874c25df.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=546088
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile7
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind9-devel/pkg-plist17
4 files changed, 22 insertions, 20 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index f46dff68043d..424ff1490822 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -48,13 +48,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.3a0.2020.08.17
+ISCVERSION= 9.17.4a0.2020.08.24
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= f85bb0691cdfe465f135c36fc6f4690d956903f1
+GL_COMMIT= 62971d4a3cade07505e28b6e5da989e02e8f7b6d
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -69,7 +69,8 @@ CONFIGURE_ARGS= --disable-linux-caps \
--with-dlopen=yes \
--with-libxml2 \
--with-openssl=${OPENSSLBASE} \
- --with-readline="-L${LOCALBASE}/lib -ledit"
+ --with-readline=libedit
+CONFIGURE_ENV= READLINE_CFLAGS="-L${LOCALBASE}/lib"
ETCDIR= ${PREFIX}/etc/namedb
.if defined(BIND_TOOLS_SLAVE)
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 29583334c0ab..777a8e7c6edd 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1597666643
-SHA256 (isc-projects-bind9-f85bb0691cdfe465f135c36fc6f4690d956903f1_GL0.tar.gz) = fe56d45bad0a650a9b3a24b28a271dde8761af9e054f4c246a0f973873bd9ce9
-SIZE (isc-projects-bind9-f85bb0691cdfe465f135c36fc6f4690d956903f1_GL0.tar.gz) = 4271204
+TIMESTAMP = 1598274694
+SHA256 (isc-projects-bind9-62971d4a3cade07505e28b6e5da989e02e8f7b6d_GL0.tar.gz) = 02c3a198dfaa749814ab3da0ca7a9350f464d3f6d5a7017fcd3144598b56e902
+SIZE (isc-projects-bind9-62971d4a3cade07505e28b6e5da989e02e8f7b6d_GL0.tar.gz) = 4269005
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 0df0acb57951..9a60114028c0 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-08-17 02:35:33 UTC
+--- bin/named/config.c.orig 2020-08-24 11:39:18 UTC
+++ bin/named/config.c
@@ -180,6 +180,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-08-17 02:35:33 UTC
+--- bin/named/server.c.orig 2020-08-24 11:39:18 UTC
+++ bin/named/server.c
@@ -4334,6 +4334,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-08-17 02:35:33 UTC
+--- lib/dns/include/dns/view.h.orig 2020-08-24 11:39:18 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-08-17 02:35:33 UTC
+--- lib/dns/resolver.c.orig 2020-08-24 11:39:18 UTC
+++ lib/dns/resolver.c
-@@ -6247,6 +6247,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6256,6 +6256,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-08-17 02:35:33 UTC
+--- lib/isccfg/namedconf.c.orig 2020-08-24 11:39:18 UTC
+++ lib/isccfg/namedconf.c
@@ -1993,6 +1993,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index ff6a06e835f1..ed61b8f3e5a5 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -194,6 +194,7 @@ include/isc/quota.h
include/isc/radix.h
include/isc/random.h
include/isc/ratelimiter.h
+include/isc/readline.h
include/isc/refcount.h
include/isc/regex.h
include/isc/region.h
@@ -264,25 +265,25 @@ include/pk11/site.h
include/pkcs11/pkcs11.h
lib/libbind9.so
lib/libbind9.so.1701
-lib/libbind9.so.1701.0.1
+lib/libbind9.so.1701.0.2
lib/libdns.so
lib/libdns.so.1703
-lib/libdns.so.1703.0.0
+lib/libdns.so.1703.1.0
lib/libirs.so
lib/libirs.so.1701
lib/libirs.so.1701.0.0
lib/libisc.so
-lib/libisc.so.1703
-lib/libisc.so.1703.0.0
+lib/libisc.so.1704
+lib/libisc.so.1704.0.0
lib/libisccc.so
-lib/libisccc.so.1701
-lib/libisccc.so.1701.0.0
+lib/libisccc.so.1702
+lib/libisccc.so.1702.0.0
lib/libisccfg.so
lib/libisccfg.so.1701
-lib/libisccfg.so.1701.0.1
+lib/libisccfg.so.1701.0.2
lib/libns.so
lib/libns.so.1703
-lib/libns.so.1703.0.0
+lib/libns.so.1703.0.1
@comment lib/named/filter-aaaa.so
@comment man/man1/arpaname.1.gz
@comment man/man1/delv.1.gz