aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-10-19 17:01:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-10-19 17:01:59 +0000
commit9a0d39ef3e34780cf842e99d0669890c4b47b32c (patch)
tree512ca571e9d0d5ca386d93766a426634fb40b509 /dns/bind9-devel
parent828e24fefd2e395b3d9145edb55795f57dc89122 (diff)
downloadports-9a0d39ef3e34780cf842e99d0669890c4b47b32c.tar.gz
ports-9a0d39ef3e34780cf842e99d0669890c4b47b32c.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=552752
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/pkg-plist11
4 files changed, 18 insertions, 17 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 9ec116ca62e4..c4b17a580fae 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -48,13 +48,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.4a0.2020.09.14
+ISCVERSION= 9.17.4a0.2020.10.15
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 00c3533a7046cda366151da68fb70ff4d0134fd8
+GL_COMMIT= a63ac933bb9116d374ca00cacf9444f8ff5f2cce
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 77bce4aa43fe..fbc7298ee8c4 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1600079727
-SHA256 (isc-projects-bind9-00c3533a7046cda366151da68fb70ff4d0134fd8_GL0.tar.gz) = ff50248443ce46d9a05848dbb51c445d48fe905e3a706376040ec7ba80630119
-SIZE (isc-projects-bind9-00c3533a7046cda366151da68fb70ff4d0134fd8_GL0.tar.gz) = 4343905
+TIMESTAMP = 1603107321
+SHA256 (isc-projects-bind9-a63ac933bb9116d374ca00cacf9444f8ff5f2cce_GL0.tar.gz) = 0c67ad9e283a79a59ed3c67a33650dec920ecff70af5f7a8f4b7bf5c7740f432
+SIZE (isc-projects-bind9-a63ac933bb9116d374ca00cacf9444f8ff5f2cce_GL0.tar.gz) = 4356534
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 1c91dd54f27c..a6bac8d90506 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-09-14 05:28:47 UTC
+--- bin/named/config.c.orig 2020-10-15 01:02:49 UTC
+++ bin/named/config.c
@@ -180,6 +180,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-09-14 05:28:47 UTC
+--- bin/named/server.c.orig 2020-10-15 01:02:49 UTC
+++ bin/named/server.c
-@@ -4343,6 +4343,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4344,6 +4344,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-09-14 05:28:47 UTC
+--- lib/dns/include/dns/view.h.orig 2020-10-15 01:02:49 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-09-14 05:28:47 UTC
+--- lib/dns/resolver.c.orig 2020-10-15 01:02:49 UTC
+++ lib/dns/resolver.c
-@@ -6265,6 +6265,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6187,6 +6187,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-09-14 05:28:47 UTC
+--- lib/isccfg/namedconf.c.orig 2020-10-15 01:02:49 UTC
+++ lib/isccfg/namedconf.c
@@ -1993,6 +1993,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 6e671855379a..5e66cf625f01 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -136,6 +136,7 @@ include/isc/base64.h
include/isc/bind9.h
include/isc/buffer.h
include/isc/bufferlist.h
+include/isc/cmocka.h
include/isc/commandline.h
include/isc/condition.h
include/isc/counter.h
@@ -268,20 +269,20 @@ lib/libbind9.so
lib/libbind9.so.1701
lib/libbind9.so.1701.0.2
lib/libdns.so
-lib/libdns.so.1703
-lib/libdns.so.1703.1.0
+lib/libdns.so.1705
+lib/libdns.so.1705.0.0
lib/libirs.so
lib/libirs.so.1701
lib/libirs.so.1701.0.0
lib/libisc.so
lib/libisc.so.1704
-lib/libisc.so.1704.0.0
+lib/libisc.so.1704.0.1
lib/libisccc.so
lib/libisccc.so.1702
lib/libisccc.so.1702.0.0
lib/libisccfg.so
-lib/libisccfg.so.1701
-lib/libisccfg.so.1701.0.2
+lib/libisccfg.so.1702
+lib/libisccfg.so.1702.0.0
lib/libns.so
lib/libns.so.1703
lib/libns.so.1703.0.1