aboutsummaryrefslogtreecommitdiff
path: root/dns/bundy
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-03-18 02:20:03 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-03-18 02:20:03 +0000
commit514b8af6970b239d4b8d7964fdaed0fa13d81c2a (patch)
treec73cd24132d23b908c2f8858a4d19a136547b07a /dns/bundy
parent8ba6fe575692431821ceaed6f1d656b6672756bb (diff)
downloadports-514b8af6970b239d4b8d7964fdaed0fa13d81c2a.tar.gz
ports-514b8af6970b239d4b8d7964fdaed0fa13d81c2a.zip
Unmark certain ports as broken on powerpc64 elfv2, after a trybroken run.
(Note that these have not yet been re-tested on elfv1.) While here, pet portlint (e.g. location of BROKEN_*, and, in one case, USES). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=528623
Diffstat (limited to 'dns/bundy')
-rw-r--r--dns/bundy/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/dns/bundy/Makefile b/dns/bundy/Makefile
index f9f91de5ec08..a82823a11439 100644
--- a/dns/bundy/Makefile
+++ b/dns/bundy/Makefile
@@ -17,6 +17,11 @@ LICENSE_NAME= ISC License
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_armv6= fails to build: Child process terminated abnormally: Segmentation fault
+BROKEN_armv7= fails to build: Child process terminated abnormally: Segmentation fault
+BROKEN_FreeBSD_11_powerpc64= fails to configure on powerpc64 elfv1: checking for botan/botan.h... no
+BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: checking for botan/botan.h... no
+
BUILD_DEPENDS= ${LOCALBASE}/include/log4cplus/logger.h:devel/log4cplus \
sqlite3>=3.3.9:databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
@@ -26,10 +31,6 @@ LIB_DEPENDS= libbotan-1.10.so:security/botan110 \
libsqlite3.so:databases/sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-BROKEN_armv6 = fails to build: Child process terminated abnormally: Segmentation fault
-BROKEN_armv7 = fails to build: Child process terminated abnormally: Segmentation fault
-BROKEN_powerpc64= fails to configure: checking for botan/botan.h... no
-
USES= compiler:c++11-lang pathfix pkgconfig libtool python:3.4+ autoreconf ssl
USE_CSTD= gnu99
USE_CXXSTD= gnu++98