aboutsummaryrefslogtreecommitdiff
path: root/dns/c-ares
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-06-10 18:36:32 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-06-10 18:36:32 +0000
commit17363b49d179d9fa2c2ddac86f2a984508354712 (patch)
tree1452350424abe944a91fbe78d0e9ad950196cfeb /dns/c-ares
parentf1263022a12c74c2db2633ec01b9ca80d0da0716 (diff)
downloadports-17363b49d179d9fa2c2ddac86f2a984508354712.tar.gz
ports-17363b49d179d9fa2c2ddac86f2a984508354712.zip
- Convert to OptionsNG
Notes
Notes: svn path=/head/; revision=298969
Diffstat (limited to 'dns/c-ares')
-rw-r--r--dns/c-ares/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index d026c0b5fe9d..e875c298a1e6 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -17,32 +17,37 @@ COMMENT= An asynchronous DNS resolver library
LICENSE= MIT
-OPTIONS= CONFIG_INFO "Add the ares_config_info patch" on \
- DEBUG "Build with debug information" off \
- HIDE_SYMBOLS "Hide internal library symbols" on \
- OPTIMIZED_CFLAGS "Build with compiler optimizations" off
+OPTIONS_DEFINE= CONFIG_INFO DEBUG HIDE_SYMBOLS OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= CONFIG_INFO HIDE_SYMBOLS
-CONFLICTS= ares-1.*
+CONFIG_INFO_DESC= Add the ares_config_info patch
+HIDE_SYMBOLS_DESC= Hide internal library symbols
+OPTIMIZED_CFLAGS_DESC= Build with compiler optimizations
+
+CONFLICTS= ares-1.*
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_CONFIG_INFO)
+.if ${PORT_OPTIONS:MCONFIG_INFO}
EXTRA_PATCHES+= ${FILESDIR}/ares-config-info.patch
PKGNAMESUFFIX= -config
.endif
-.if defined(WITH_DEBUG)
+
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.else
CONFIGURE_ARGS+=--disable-debug
.endif
-.if defined(WITH_HIDE_SYMBOLS)
+
+.if ${PORT_OPTIONS:MHIDE_SYMBOLS}
CONFIGURE_ARGS+=--enable-symbol-hiding
.else
CONFIGURE_ARGS+=--disable-symbol-hiding
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CONFIGURE_ARGS+=--enable-optimize
.else
CONFIGURE_ARGS+=--disable-optimize