aboutsummaryrefslogtreecommitdiff
path: root/dns/cli53
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2015-04-29 20:24:44 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2015-04-29 20:24:44 +0000
commit7b4f7e2c6f55314a1834a58642016722456b35fb (patch)
treefe04a08febc28ddaf1fb33479325f1299a2cdd69 /dns/cli53
parent71806fd113a015fb9cea77254fd6983c56c6f5a9 (diff)
downloadports-7b4f7e2c6f55314a1834a58642016722456b35fb.tar.gz
ports-7b4f7e2c6f55314a1834a58642016722456b35fb.zip
New port: dns/cli53:
cli53 provides import and export from BIND format and simple command line management of Route 53 domains. WWW: https://github.com/barnybug/cli53/
Notes
Notes: svn path=/head/; revision=385011
Diffstat (limited to 'dns/cli53')
-rw-r--r--dns/cli53/Makefile23
-rw-r--r--dns/cli53/distinfo2
-rw-r--r--dns/cli53/pkg-descr4
-rw-r--r--dns/cli53/pkg-message13
4 files changed, 42 insertions, 0 deletions
diff --git a/dns/cli53/Makefile b/dns/cli53/Makefile
new file mode 100644
index 000000000000..1f4315731892
--- /dev/null
+++ b/dns/cli53/Makefile
@@ -0,0 +1,23 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cli53
+PORTVERSION= 0.4.4
+CATEGORIES= dns
+MASTER_SITES= GH GHC
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Command line management of Route53 domains
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:${PORTSDIR}/devel/py-boto \
+ ${PYTHON_PKGNAMEPREFIX}argparse>0:${PORTSDIR}/devel/py-argparse \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>0:${PORTSDIR}/dns/py-dnspython
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= barnybug
+GH_TAGNAME= ${PORTVERSION}
+GH_COMMIT= 0885f8c
+
+.include <bsd.port.mk>
diff --git a/dns/cli53/distinfo b/dns/cli53/distinfo
new file mode 100644
index 000000000000..120d3293148a
--- /dev/null
+++ b/dns/cli53/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cli53-0.4.4.tar.gz) = 9803ef447a7277002fe05810de0285d7aad9c4f2c420844f87f6ca3f5491c4a7
+SIZE (cli53-0.4.4.tar.gz) = 15896
diff --git a/dns/cli53/pkg-descr b/dns/cli53/pkg-descr
new file mode 100644
index 000000000000..e32992ae68d9
--- /dev/null
+++ b/dns/cli53/pkg-descr
@@ -0,0 +1,4 @@
+cli53 provides import and export from BIND format and simple command
+line management of Route 53 domains.
+
+WWW: https://github.com/barnybug/cli53/
diff --git a/dns/cli53/pkg-message b/dns/cli53/pkg-message
new file mode 100644
index 000000000000..98dddf4d81b9
--- /dev/null
+++ b/dns/cli53/pkg-message
@@ -0,0 +1,13 @@
+Please configure your AWS credentials, either through environment variables or
+~/.boto config file.
+
+For example:
+
+export AWS_ACCESS_KEY_ID=XXXXXXXXXXXXXX
+export AWS_SECRET_ACCESS_KEY=XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
+
+or in ~/.boto (make sure you chmod 600 ~/.boto):
+
+[Credentials]
+aws_access_key_id = XXXXXXXXXXXXXX
+aws_secret_access_key = XXXXXXXXXXXXXXXXXXXXXXXXXXXXX