aboutsummaryrefslogtreecommitdiff
path: root/dns/ddclient/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2010-08-17 19:22:56 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2010-08-17 19:22:56 +0000
commite3bea4f57f6ad5d7f145ebbfd6444c1fc6d71464 (patch)
tree92e8fdf0bc5b089e38f2fdb9efa23fb1d733d32a /dns/ddclient/Makefile
parentcc632e14828e8657a23c3d61ec3d65a584e22002 (diff)
downloadports-e3bea4f57f6ad5d7f145ebbfd6444c1fc6d71464.tar.gz
ports-e3bea4f57f6ad5d7f145ebbfd6444c1fc6d71464.zip
Notes
Diffstat (limited to 'dns/ddclient/Makefile')
-rw-r--r--dns/ddclient/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index 6fa37d705e58..cc319992155a 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ddclient
PORTVERSION= 3.8.0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -17,14 +18,15 @@ COMMENT= Update dynamic DNS entries
RUN_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
.endif
+LICENSE= GPLv2
+
USE_BZIP2= yes
USE_PERL5_RUN= yes
NO_BUILD= yes
USE_RC_SUBR= ${PORTNAME}
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message ddclient_force
PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_FILES= etc/ddclient.conf.sample sbin/ddclient
PORTDOCS= COPYING COPYRIGHT Changelog README README.cisco README.ssl \
sample-etc_cron.d_ddclient sample-etc_dhclient-exit-hooks \
@@ -46,6 +48,10 @@ do-install:
@${INSTALL} -d ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/periodic/daily
+ ${INSTALL_SCRIPT} ${WRKDIR}/ddclient_force ${PREFIX}/etc/periodic/daily/ddclient_force
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>