aboutsummaryrefslogtreecommitdiff
path: root/dns/ddclient
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-11-07 01:07:05 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-11-07 01:07:05 +0000
commit645be2992761d907bfb49b0ec776ac162fd6b7d8 (patch)
treeaa1c0a13fefe970e68473c07319ad749037652ea /dns/ddclient
parentba7c34bd0a01ac88db56075102c7323c9ec3b0ee (diff)
downloadports-645be2992761d907bfb49b0ec776ac162fd6b7d8.tar.gz
ports-645be2992761d907bfb49b0ec776ac162fd6b7d8.zip
Notes
Diffstat (limited to 'dns/ddclient')
-rw-r--r--dns/ddclient/Makefile13
-rw-r--r--dns/ddclient/distinfo2
-rw-r--r--dns/ddclient/files/patch-ab50
-rw-r--r--dns/ddclient/pkg-descr2
-rw-r--r--dns/ddclient/pkg-plist2
5 files changed, 60 insertions, 9 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index 6197d2a94e8b..41515fc133ab 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ddclient
-PORTVERSION= 3.6.2
+PORTVERSION= 3.6.3
CATEGORIES= dns
MASTER_SITES= http://members.rogers.com/ddclient/pub/
@@ -17,18 +17,19 @@ USE_PERL5= yes
NO_BUILD= yes
do-install:
- @/usr/bin/perl -pi -e 's|%%PREFIX%%|${PREFIX}|g; s|%%PERL%%|${PERL}|g' ${WRKSRC}/ddclient
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g; s|%%PERL%%|${PERL}|g' ${WRKSRC}/ddclient
@${INSTALL_SCRIPT} ${WRKSRC}/ddclient ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKSRC}/sample-etc_ddclient.conf ${PREFIX}/etc/ddclient.conf.sample
@${MKDIR} ${PREFIX}/share/ddclient
.for i in COPYING COPYRIGHT README README.cisco sample-etc_cron.d_ddclient \
- sample-etc_dhclient-enter-hooks sample-etc_dhcpc_dhcpcd-eth0.exe \
+ sample-etc_dhclient-exit-hooks sample-etc_dhcpc_dhcpcd-eth0.exe \
sample-etc_ppp_ip-up.local
- @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/ddclient
+ @${PERL} -pe 's|%%PREFIX%%|${PREFIX}|g' < ${WRKSRC}/$i > ${WRKDIR}/$i
+ @${INSTALL_DATA} ${WRKDIR}/$i ${PREFIX}/share/ddclient
.endfor
- @/usr/bin/perl -pe 's|%%PREFIX%%|${PREFIX}|g' < ${FILESDIR}/ddclient.sh.sample > ${WRKDIR}/ddclient.sh.sample
+ @${PERL} -pe 's|%%PREFIX%%|${PREFIX}|g' < ${FILESDIR}/ddclient.sh.sample > ${WRKDIR}/ddclient.sh.sample
@${INSTALL_SCRIPT} ${WRKDIR}/ddclient.sh.sample ${PREFIX}/etc/rc.d
- @/usr/bin/perl -pe 's|/usr/local|${PREFIX}|g' < ${PKGMESSAGE}
+ @${PERL} -pe 's|/usr/local|${PREFIX}|g' < ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/dns/ddclient/distinfo b/dns/ddclient/distinfo
index 8d47716e57f6..f5a0477070d8 100644
--- a/dns/ddclient/distinfo
+++ b/dns/ddclient/distinfo
@@ -1 +1 @@
-MD5 (ddclient-3.6.2.tar.gz) = 40741dbf315889b1bd1b08e36ca665c0
+MD5 (ddclient-3.6.3.tar.gz) = dfa5ff6967cb854de804d4e7b9633fdc
diff --git a/dns/ddclient/files/patch-ab b/dns/ddclient/files/patch-ab
new file mode 100644
index 000000000000..70b376a45b90
--- /dev/null
+++ b/dns/ddclient/files/patch-ab
@@ -0,0 +1,50 @@
+--- sample-etc_cron.d_ddclient.orig Sun Jun 15 03:39:16 2003
++++ sample-etc_cron.d_ddclient Thu Aug 7 14:31:15 2003
+@@ -10,8 +10,8 @@
+ ######################################################################
+ ## force an update twice a month (only if you are not using daemon-mode)
+ ##
+-## 30 23 1,15 * * root /usr/sbin/ddclient -daemon=0 -syslog -quiet -force
++## 30 23 1,15 * * root %%PREFIX%%/sbin/ddclient -daemon=0 -syslog -quiet -force
+ ######################################################################
+ ## retry failed updates every hour (only if you are not using daemon-mode)
+ ##
+-##0 * * * * root /usr/sbin/ddclient -daemon=0 -syslog -quiet retry
++##0 * * * * root %%PREFIX%%/sbin/ddclient -daemon=0 -syslog -quiet retry
+--- sample-etc_dhclient-exit-hooks.orig Sun Jun 15 03:39:16 2003
++++ sample-etc_dhclient-exit-hooks Thu Aug 7 14:38:38 2003
+@@ -2,10 +2,10 @@
+ ######################################################################
+ ## $Header: /home/paul/src/ddclient/RCS/sample-etc_dhclient-exit-hooks,v 1.1 2002/11/03 20:20:16 root Exp $
+ ######################################################################
+-# The /etc/dhclient-enter-hooks script is run by the ISC DHCP client's standard
++# The /etc/dhclient-exit-hooks script is run by the ISC DHCP client's standard
+ # update script whenever dhclient obtains or renews an address.
+
+-PATH=/usr/sbin:${PATH}
++PATH=%%PREFIX%%/sbin:${PATH}
+ case "$new_ip_address" in
+ 10.*) ;;
+ 172.1[6-9].* | 172.2[0-9].* | 172.3[0-1].*) ;;
+--- sample-etc_dhcpc_dhcpcd-eth0.exe.orig Sun Jun 15 03:39:16 2003
++++ sample-etc_dhcpc_dhcpcd-eth0.exe Thu Aug 7 14:33:00 2003
+@@ -2,7 +2,7 @@
+ ######################################################################
+ ## $Header: /home/paul/src/ddclient/RCS/sample-etc_dhcpc_dhcpcd-eth0.exe,v 3.6 2002/11/03 20:20:16 root Exp $
+ ######################################################################
+-PATH=/usr/sbin:${PATH}
++PATH=%%PREFIX%%/sbin:${PATH}
+
+ ## update the DNS server unless the IP address is a private address
+ ## that may be used as a internal LAN address. This may be true if
+--- sample-etc_ppp_ip-up.local.orig Sun Jun 15 03:39:16 2003
++++ sample-etc_ppp_ip-up.local Thu Aug 7 14:33:32 2003
+@@ -16,7 +16,7 @@
+ ## in the environment as either PPP_LOCAL or IPLOCAL.
+ ##
+ ######################################################################
+-PATH=/usr/sbin:${PATH}
++PATH=%%PREFIX%%/sbin:${PATH}
+ IP=
+ IP=${IP:-$PPP_LOCAL}
+ IP=${IP:-$IPLOCAL}
diff --git a/dns/ddclient/pkg-descr b/dns/ddclient/pkg-descr
index 584b41cf5069..efddd008704b 100644
--- a/dns/ddclient/pkg-descr
+++ b/dns/ddclient/pkg-descr
@@ -1,4 +1,4 @@
ddclient is a Perl client used to update dynamic DNS entries for
accounts on many dynamic DNS services.
-WWW: http://burry.ca:4141/ddclient/
+WWW: http://members.rogers.com/ddclient/pub/
diff --git a/dns/ddclient/pkg-plist b/dns/ddclient/pkg-plist
index b72aa7765220..d94a95d99a41 100644
--- a/dns/ddclient/pkg-plist
+++ b/dns/ddclient/pkg-plist
@@ -6,7 +6,7 @@ share/ddclient/COPYRIGHT
share/ddclient/README
share/ddclient/README.cisco
share/ddclient/sample-etc_cron.d_ddclient
-share/ddclient/sample-etc_dhclient-enter-hooks
+share/ddclient/sample-etc_dhclient-exit-hooks
share/ddclient/sample-etc_dhcpc_dhcpcd-eth0.exe
share/ddclient/sample-etc_ppp_ip-up.local
@dirrm share/ddclient