aboutsummaryrefslogtreecommitdiff
path: root/dns/ddclient
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-08-26 16:07:09 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-08-26 16:07:09 +0000
commitd588562aa0d585fe11cf8b8ee68ef5f8d71e512c (patch)
tree79c4c6bbc3706811612610f5673d8ff950f0616b /dns/ddclient
parent072d3711d6b7ce455790b0addd845733988534ca (diff)
downloadports-d588562aa0d585fe11cf8b8ee68ef5f8d71e512c.tar.gz
ports-d588562aa0d585fe11cf8b8ee68ef5f8d71e512c.zip
Notes
Diffstat (limited to 'dns/ddclient')
-rw-r--r--dns/ddclient/Makefile33
-rw-r--r--dns/ddclient/distinfo1
-rw-r--r--dns/ddclient/files/ddclient.sh.sample18
-rw-r--r--dns/ddclient/files/patch-aa25
-rw-r--r--dns/ddclient/pkg-comment1
-rw-r--r--dns/ddclient/pkg-descr4
-rw-r--r--dns/ddclient/pkg-message19
-rw-r--r--dns/ddclient/pkg-plist12
8 files changed, 113 insertions, 0 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
new file mode 100644
index 000000000000..369c4fd3ea2d
--- /dev/null
+++ b/dns/ddclient/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ddclient
+# Date created: Sun Aug 26 14:45:12 CEST 2001
+# Whom: Dirk Froemberg <dirk@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ddclient
+PORTVERSION= 3.4.5
+CATEGORIES= net
+MASTER_SITES= http://burry.ca:4141/ddclient/
+
+MAINTAINER= dirk@FreeBSD.org
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+do-install:
+ @/usr/bin/perl -pi -e 's|%%PREFIX%%|${PREFIX}|g; s|%%PERL%%|${PERL}|g' ${WRKSRC}/ddclient
+ @${INSTALL_SCRIPT} ${WRKSRC}/ddclient ${PREFIX}/sbin
+ @${INSTALL_DATA} ${WRKSRC}/sample-etc_ddclient.conf ${PREFIX}/etc/ddclient.conf.sample
+ @${MKDIR} ${PREFIX}/share/ddclient
+.for i in COPYING COPYRIGHT README README.cisco sample-etc_cron.d_ddclient \
+ sample-etc_dhclient-enter-hooks sample-etc_dhcpc_dhcpcd-eth0.exe \
+ sample-etc_ppp_ip-up.local
+ @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/ddclient
+.endfor
+ @/usr/bin/perl -pe 's|%%PREFIX%%|${PREFIX}|g' < ${FILESDIR}/ddclient.sh.sample > ${WRKDIR}/ddclient.sh.sample
+ @${INSTALL_SCRIPT} ${WRKDIR}/ddclient.sh.sample ${PREFIX}/etc/rc.d
+
+ @/usr/bin/perl -pe 's|/usr/local|${PREFIX}|g' < ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/dns/ddclient/distinfo b/dns/ddclient/distinfo
new file mode 100644
index 000000000000..b9c3b7862d17
--- /dev/null
+++ b/dns/ddclient/distinfo
@@ -0,0 +1 @@
+MD5 (ddclient-3.4.5.tar.gz) = 7d2c89161e5aa87aa1e27b5741afc029
diff --git a/dns/ddclient/files/ddclient.sh.sample b/dns/ddclient/files/ddclient.sh.sample
new file mode 100644
index 000000000000..7d849d315d7b
--- /dev/null
+++ b/dns/ddclient/files/ddclient.sh.sample
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ if [ -x %%PREFIX%%/sbin/ddclient ]; then
+ %%PREFIX%%/sbin/ddclient -daemon 300 && echo -n ' ddclient'
+ fi
+ ;;
+ stop)
+ /usr/bin/killall ddclient
+ echo -n ' ddclient'
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 64
+ ;;
+esac
diff --git a/dns/ddclient/files/patch-aa b/dns/ddclient/files/patch-aa
new file mode 100644
index 000000000000..fdf4b1f30fcb
--- /dev/null
+++ b/dns/ddclient/files/patch-aa
@@ -0,0 +1,25 @@
+--- ddclient.orig Sun Jul 22 23:23:11 2001
++++ ddclient Sun Aug 26 14:56:45 2001
+@@ -1,5 +1,4 @@
+-#!/usr/bin/perl -w
+-#!/usr/local/bin/perl -w
++#!%%PERL%% -w
+ ######################################################################
+ # $Header: /home/paul/src/ddclient/RCS/ddclient,v 1.91 2001/07/22 21:01:33 root Exp $
+ #
+@@ -20,12 +19,12 @@
+ $program =~ s/d$//;
+ my $now = time;
+ my $hostname = hostname();
+-my $etc = ($program =~ /test/i) ? './' : '/etc/';
+-my $savedir = ($program =~ /test/i) ? 'URL/' : '/tmp/';
++my $etc = '%%PREFIX%%/etc';
++my $savedir = (exists($ENV{TMPDIR}) ? "$ENV{TMPDIR}" : "/var/tmp");
+ my $msgs = '';
+ my $last_msgs = '';
+
+-$ENV{'PATH'} = (exists($ENV{PATH}) ? "$ENV{PATH}:" : "") . "/sbin:/usr/sbin:/bin:/usr/bin:/etc:/usr/lib:";
++$ENV{'PATH'} = (exists($ENV{PATH}) ? "$ENV{PATH}:" : "") . "/sbin:/usr/sbin:/bin:/usr/bin";
+
+ sub T_ANY {'any'};
+ sub T_STRING {'string'};
diff --git a/dns/ddclient/pkg-comment b/dns/ddclient/pkg-comment
new file mode 100644
index 000000000000..4461f5b763e4
--- /dev/null
+++ b/dns/ddclient/pkg-comment
@@ -0,0 +1 @@
+Update dynamic DNS entries
diff --git a/dns/ddclient/pkg-descr b/dns/ddclient/pkg-descr
new file mode 100644
index 000000000000..584b41cf5069
--- /dev/null
+++ b/dns/ddclient/pkg-descr
@@ -0,0 +1,4 @@
+ddclient is a Perl client used to update dynamic DNS entries for
+accounts on many dynamic DNS services.
+
+WWW: http://burry.ca:4141/ddclient/
diff --git a/dns/ddclient/pkg-message b/dns/ddclient/pkg-message
new file mode 100644
index 000000000000..a024f33a9649
--- /dev/null
+++ b/dns/ddclient/pkg-message
@@ -0,0 +1,19 @@
+
+***********************************************************
+Copy
+
+ /usr/local/etc/ddclient.conf.sample
+to
+ /usr/local/etc/ddclient.conf
+
+and edit it to fit your needs.
+
+If you would like to run ddclient as a daemon consider
+copying
+
+ /usr/local/etc/rc.d/ddclient.sh.sample
+to
+ /usr/local/etc/rc.d/ddclient.sh
+
+***********************************************************
+
diff --git a/dns/ddclient/pkg-plist b/dns/ddclient/pkg-plist
new file mode 100644
index 000000000000..b72aa7765220
--- /dev/null
+++ b/dns/ddclient/pkg-plist
@@ -0,0 +1,12 @@
+etc/ddclient.conf.sample
+etc/rc.d/ddclient.sh.sample
+sbin/ddclient
+share/ddclient/COPYING
+share/ddclient/COPYRIGHT
+share/ddclient/README
+share/ddclient/README.cisco
+share/ddclient/sample-etc_cron.d_ddclient
+share/ddclient/sample-etc_dhclient-enter-hooks
+share/ddclient/sample-etc_dhcpc_dhcpcd-eth0.exe
+share/ddclient/sample-etc_ppp_ip-up.local
+@dirrm share/ddclient