aboutsummaryrefslogtreecommitdiff
path: root/dns/djbdns
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2018-01-16 19:54:19 +0000
committerDavid Thiel <lx@FreeBSD.org>2018-01-16 19:54:19 +0000
commite9595bcc432397f851bbd34ecef546609509143b (patch)
treecbce8108ad64a19043d84ec1fc4c7a1a3f9a49a0 /dns/djbdns
parent2a4a05ce1561261e95f4438c837bea6b0d1596fb (diff)
downloadports-e9595bcc432397f851bbd34ecef546609509143b.tar.gz
ports-e9595bcc432397f851bbd34ecef546609509143b.zip
Bump loop detection limit to 500
PR: 216260 Submitted by: tjd-freebsd@phlegethon.org
Notes
Notes: svn path=/head/; revision=459204
Diffstat (limited to 'dns/djbdns')
-rw-r--r--dns/djbdns/Makefile2
-rw-r--r--dns/djbdns/files/patch-query.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
index 09267d3173ef..980c00bd3477 100644
--- a/dns/djbdns/Makefile
+++ b/dns/djbdns/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= djbdns
PORTVERSION?= ${DJBDNS_VER}
-PORTREVISION?= 21
+PORTREVISION?= 22
PORTEPOCH?= 1
CATEGORIES?= dns
MASTER_SITES= http://cr.yp.to/djbdns/ \
diff --git a/dns/djbdns/files/patch-query.c b/dns/djbdns/files/patch-query.c
new file mode 100644
index 000000000000..34663213dff6
--- /dev/null
+++ b/dns/djbdns/files/patch-query.c
@@ -0,0 +1,20 @@
+--- query.c.orig 2018-01-16 11:49:56.341179000 -0800
++++ query.c 2018-01-16 11:50:06.432700000 -0800
+@@ -203,7 +203,7 @@
+
+
+ NEWNAME:
+- if (++z->loop == 100) goto DIE;
++ if (++z->loop == 500) goto DIE;
+ d = z->name[z->level];
+ dtype = z->level ? DNS_T_A : z->type;
+ dlen = dns_domain_length(d);
+@@ -449,7 +449,7 @@
+
+
+ HAVEPACKET:
+- if (++z->loop == 100) goto DIE;
++ if (++z->loop == 500) goto DIE;
+ buf = z->dt.packet;
+ len = z->dt.packetlen;
+