aboutsummaryrefslogtreecommitdiff
path: root/dns/dnscrypt-proxy2
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:29:39 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:29:39 +0000
commit34156e93e84fe00711fac9dbf19e33534dc665f9 (patch)
tree644edaf7864f48d3652926a9f242a0f01e0cdf92 /dns/dnscrypt-proxy2
parentff71c9d91c68253cfaa8c6a682953afd5329b26f (diff)
downloadports-34156e93e84fe00711fac9dbf19e33534dc665f9.tar.gz
ports-34156e93e84fe00711fac9dbf19e33534dc665f9.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. audio-mail)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 - Switch to go:modules when upstream already uses them Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21741
Notes
Notes: svn path=/head/; revision=513274
Diffstat (limited to 'dns/dnscrypt-proxy2')
-rw-r--r--dns/dnscrypt-proxy2/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/dns/dnscrypt-proxy2/Makefile b/dns/dnscrypt-proxy2/Makefile
index 7d1b39eb268a..242816fcfec7 100644
--- a/dns/dnscrypt-proxy2/Makefile
+++ b/dns/dnscrypt-proxy2/Makefile
@@ -13,12 +13,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ca_root_nss>=3.35:security/ca_root_nss
-USES= go
+USES= go:modules
USE_RC_SUBR= ${PORTNAME}
USE_GITHUB= yes
GH_ACCOUNT= jedisct1
+GO_TARGET= ./dnscrypt-proxy:${PREFIX}/sbin/dnscrypt-proxy
+
USERS= _dnscrypt-proxy
GROUPS= _dnscrypt-proxy
@@ -33,16 +35,6 @@ CONFLICTS_INSTALL= dnscrypt-proxy
OPTIONS_DEFINE= DOCS EXAMPLES
-do-build:
- ${RLN} ${WRKSRC}/vendor ${WRKSRC}/src
- ${RM} ${WRKSRC}/go.mod
- cd ${WRKSRC}/${PORTNAME} && \
- ${SETENV} ${MAKE_ENV} ${GO_ENV} GOPATH=${WRKSRC} \
- ${GO_CMD} build ${GO_BUILDFLAGS} -o ${WRKDIR}/sbin/${PORTNAME}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/sbin/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
-
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}