aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq-devel
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-05-21 11:05:56 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-05-21 11:05:56 +0000
commit9016fa489d235367890b0d8dddf7079650e3bb30 (patch)
treede46f8c262c5e3efc4483a064e39a60eb6cca4ed /dns/dnsmasq-devel
parente46c64480bece5cc2fdab44ee6a51a53ed4df1f0 (diff)
downloadports-9016fa489d235367890b0d8dddf7079650e3bb30.tar.gz
ports-9016fa489d235367890b0d8dddf7079650e3bb30.zip
Update to upstream release candidate #4, with two more fixes.
Additionally, zero out *addrp in edns0.c, and fix two typoes in forward.c where && should be &. These fixes have all been reported upstream. Note that the build rig is currently not up to using I18N and IDN2, so we forgo IDN2 for now. Also reported upstream. Changelog since -test5: 1835343 (tag: v2.77rc4) Update German translation. 2aaea18 Add .gitattributes to substitute VERSION on export. 7ab78b9 (tag: v2.77rc3) Fix c7be0164ce6ae89d6f2f0ffea14e2612418dd5da c7be016 (tag: v2.77rc2) Suppress DHCP ping checks when allocating on the loopback interface. d203af4 Add optional support for libidn2 and therefore IDNA2008. 05f76da Don't die() on failing to parse lease-script output. bf05f8f Fix crash introduced by 09f3b2cd9c7b5b5e0e96ba41f666e69808862620. 09f3b2c (tag: v2.77rc1) Fix case of DS queries to domains marked as not doing DNSSEC. 2282787 Fix botch introduced by 561441320f0cb67ea97f81c59332da5c6d14b494 4583dd9 Replace obsolete utime() usage with utimes(). 5614413 Fix a couple of crashes on malformed config files. b2a9c57 Add "known-othernet" DHCP tag.
Notes
Notes: svn path=/head/; revision=441373
Diffstat (limited to 'dns/dnsmasq-devel')
-rw-r--r--dns/dnsmasq-devel/Makefile8
-rw-r--r--dns/dnsmasq-devel/distinfo6
-rw-r--r--dns/dnsmasq-devel/files/patch-src_edns0.c11
-rw-r--r--dns/dnsmasq-devel/files/patch-src_forward.c20
4 files changed, 38 insertions, 7 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index f048accc1c9d..16b560893bfe 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.77test5
-PORTEPOCH= 1
+DISTVERSION= 2.77rc4
+PORTEPOCH= 2
CATEGORIES= dns ipv6
-#MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/release-candidates/
-MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/test-releases/
+MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/release-candidates/
+#MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/test-releases/
PKGNAMESUFFIX= -devel
MAINTAINER= mandree@FreeBSD.org
diff --git a/dns/dnsmasq-devel/distinfo b/dns/dnsmasq-devel/distinfo
index a2807e341854..f9bb4196c548 100644
--- a/dns/dnsmasq-devel/distinfo
+++ b/dns/dnsmasq-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493933562
-SHA256 (dnsmasq-2.77test5.tar.xz) = 5d57d575944769f4c6142ac3d6e81c3e60f20f6817d52f18df8056b6e0a9112d
-SIZE (dnsmasq-2.77test5.tar.xz) = 502964
+TIMESTAMP = 1495362006
+SHA256 (dnsmasq-2.77rc4.tar.xz) = e357de7faa5fb34098635b7f6000a16cc7aa703a9c41de9d392b4ef594eb1abb
+SIZE (dnsmasq-2.77rc4.tar.xz) = 503480
diff --git a/dns/dnsmasq-devel/files/patch-src_edns0.c b/dns/dnsmasq-devel/files/patch-src_edns0.c
new file mode 100644
index 000000000000..aba513dacc61
--- /dev/null
+++ b/dns/dnsmasq-devel/files/patch-src_edns0.c
@@ -0,0 +1,11 @@
+--- src/edns0.c.orig 2017-05-12 14:16:02 UTC
++++ src/edns0.c
+@@ -304,7 +304,7 @@ static size_t calc_subnet_opt(struct sub
+ /* http://tools.ietf.org/html/draft-vandergaast-edns-client-subnet-02 */
+
+ int len;
+- void *addrp;
++ void *addrp = NULL;
+ int sa_family = source->sa.sa_family;
+
+ opt->source_netmask = 0;
diff --git a/dns/dnsmasq-devel/files/patch-src_forward.c b/dns/dnsmasq-devel/files/patch-src_forward.c
new file mode 100644
index 000000000000..07d050da8de9
--- /dev/null
+++ b/dns/dnsmasq-devel/files/patch-src_forward.c
@@ -0,0 +1,20 @@
+--- src/forward.c.orig 2017-05-12 14:16:02 UTC
++++ src/forward.c
+@@ -899,7 +899,7 @@ void reply_query(int fd, int family, tim
+ status = dnssec_validate_ds(now, header, n, daemon->namebuff, daemon->keyname, forward->class);
+ else
+ status = dnssec_validate_reply(now, header, n, daemon->namebuff, daemon->keyname, &forward->class,
+- option_bool(OPT_DNSSEC_NO_SIGN) && (server->flags && SERV_DO_DNSSEC), NULL, NULL);
++ option_bool(OPT_DNSSEC_NO_SIGN) && (server->flags & SERV_DO_DNSSEC), NULL, NULL);
+ }
+
+ /* Can't validate, as we're missing key data. Put this
+@@ -1477,7 +1477,7 @@ static int tcp_key_recurse(time_t now, i
+ new_status = dnssec_validate_ds(now, header, n, name, keyname, class);
+ else
+ new_status = dnssec_validate_reply(now, header, n, name, keyname, &class,
+- option_bool(OPT_DNSSEC_NO_SIGN) && (server->flags && SERV_DO_DNSSEC), NULL, NULL);
++ option_bool(OPT_DNSSEC_NO_SIGN) && (server->flags & SERV_DO_DNSSEC), NULL, NULL);
+
+ if (new_status != STAT_NEED_DS && new_status != STAT_NEED_KEY)
+ break;