aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-06-03 02:03:40 +0000
committerWill Andrews <will@FreeBSD.org>2003-06-03 02:03:40 +0000
commit0521957a163a60ae2be5902ae888a4bf5585462b (patch)
treeb7f16e0ec691c877e7a81a850da3706e60a7478e /dns/dnsmasq/Makefile
parent80b21198f531f2d8380f81e1b91ce2f90f9e02e8 (diff)
downloadports-0521957a163a60ae2be5902ae888a4bf5585462b.tar.gz
ports-0521957a163a60ae2be5902ae888a4bf5585462b.zip
Notes
Diffstat (limited to 'dns/dnsmasq/Makefile')
-rw-r--r--dns/dnsmasq/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
new file mode 100644
index 000000000000..d9ccc65bf3c0
--- /dev/null
+++ b/dns/dnsmasq/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dnsmasq
+# Date created: 1 June 2003
+# Whom: Steven Honson <shonson@isoproplex.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnsmasq
+PORTVERSION= 1.12
+CATEGORIES= net
+MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
+
+MAINTAINER= shonson@isoproplex.net
+COMMENT= A caching DNS forwarder
+
+.if defined(WITH_IPV6)
+CFLAGS += -DWITH_IPV6
+.endif
+
+MAN8= dnsmasq.8
+
+pre-fetch:
+.if !defined(WITH_IPV6)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "Define WITH_IPV6 to build dnsmasq with IPv6 support."
+ @${ECHO_CMD} ""
+.endif
+
+.include <bsd.port.mk>