aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /dns/dnsmasq/Makefile
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
downloadports-4e1b79a0a61f4973df8b4b0864d22086c769e219.tar.gz
ports-4e1b79a0a61f4973df8b4b0864d22086c769e219.zip
Notes
Diffstat (limited to 'dns/dnsmasq/Makefile')
-rw-r--r--dns/dnsmasq/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index a5af54da048d..f631a513302c 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -47,7 +47,7 @@ CFLAGS+= -DNO_IPV6
.if ${PORT_OPTIONS:MNLS}
USES+= gettext gmake iconv pkgconfig
-LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:dns/libidn
PLIST_SUB+= NLS=""
ALL_TARGET= all-i18n
_intllibs= -lintl
@@ -57,13 +57,13 @@ PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MIDN}
USES+= iconv
CFLAGS+= -DHAVE_IDN
-LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:dns/libidn
_intllibs+= -lidn
.endif
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= libdbus-1.so:devel/dbus
USES+= pkgconfig
CPPFLAGS+= `pkg-config --cflags dbus-1`
CFLAGS+= -DHAVE_DBUS
@@ -80,8 +80,8 @@ USES+= lua
.if ${PORT_OPTIONS:MDNSSEC}
CFLAGS+= -DHAVE_DNSSEC
USES+= pkgconfig
-LIB_DEPENDS+= libnettle.so:${PORTSDIR}/security/nettle
-LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libnettle.so:security/nettle
+LIB_DEPENDS+= libgmp.so:math/gmp
.endif
USE_RC_SUBR= dnsmasq