aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-06-01 17:55:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-06-01 17:55:27 +0000
commit56117f87e151bd10e16553f2a30a7c4f7bf20827 (patch)
treee7d8d6716bcf2c9d57f145865c998a43c626c190 /dns/dnsmasq/Makefile
parent1817eddea2a22ebe63f425e22bb1aae938f047fc (diff)
downloadports-56117f87e151bd10e16553f2a30a7c4f7bf20827.tar.gz
ports-56117f87e151bd10e16553f2a30a7c4f7bf20827.zip
Notes
Diffstat (limited to 'dns/dnsmasq/Makefile')
-rw-r--r--dns/dnsmasq/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 914228f06850..908dee564892 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.76
+DISTVERSION= 2.77
PORTREVISION= 0 # leave this in even if 0 to avoid PORTEPOCH bumps
PORTEPOCH= 1
CATEGORIES= dns ipv6
@@ -20,7 +20,7 @@ PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
SUB_FILES= pkg-message
-CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter
+CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter -Wno-unused-variable -Wno-unused-function
CPPFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" COPTS="${CFLAGS}" LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
@@ -47,18 +47,19 @@ IPSET_CFLAGS_OFF=-DNO_IPSET
.if ${PORT_OPTIONS:MNLS}
USES+= gettext gmake iconv pkgconfig
-LIB_DEPENDS+= libidn.so:dns/libidn
+CFLAGS+= -DHAVE_LIBIDN2
+LIB_DEPENDS+= libidn2.so:dns/libidn2
PLIST_SUB+= NLS=""
ALL_TARGET= all-i18n
-_intllibs= -lintl
+_intllibs= -lidn2 -lintl
.else
_intllibs=
PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MIDN}
USES+= iconv
-CFLAGS+= -DHAVE_IDN
-LIB_DEPENDS+= libidn.so:dns/libidn
-_intllibs+= -lidn
+CFLAGS+= -DHAVE_LIBIDN2
+LIB_DEPENDS+= libidn2.so:dns/libidn2
+_intllibs+= -lidn2
.endif
.endif
@@ -96,10 +97,10 @@ post-patch:
pre-configure: pretty-print-config
.if ${PORT_OPTIONS:MIDN}
.if empty(PORT_OPTIONS:MNLS)
- @if ${READELF} -d ${LOCALBASE}/lib/libidn.so \
+ @if ${READELF} -d ${LOCALBASE}/lib/libidn2.so \
| ${EGREP} -q '\<NEEDED\>.*\[libintl\.so' ; \
- then ${ECHO} ; ${ECHO} 'WARNING: dns/libidn was compiled with NLS support!' ; \
- ${ECHO} 'Recompile libidn WITHOUT_NLS to get rid of NLS dependencies.' ; ${ECHO} ; \
+ then ${ECHO} ; ${ECHO} 'WARNING: dns/libidn2 was compiled with NLS support!' ; \
+ ${ECHO} 'Recompile libidn2 WITHOUT_NLS to get rid of NLS dependencies.' ; ${ECHO} ; \
fi
.else
@${ECHO} 'WARNING: IDN and NLS enabled, building IDN WITH NLS.'