aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsrecon
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-05-29 11:00:02 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-05-29 11:00:02 +0000
commitbee9ab2699a55f4771ed213303c6e950069b739f (patch)
treefba0cd3d05cefd155ac0f4c7d3a8e563eb9c1b0a /dns/dnsrecon
parent19f0ab9fceebd069a1e3ac64c71bfe6e34d3dabb (diff)
downloadports-bee9ab2699a55f4771ed213303c6e950069b739f.tar.gz
ports-bee9ab2699a55f4771ed213303c6e950069b739f.zip
DNSRecon provides the ability to perform:
Check all NS Records for Zone Transfers. Enumerate General DNS Records for a given Domain (MX, SOA, NS, A, AAAA, SPF and TXT). Perform common SRV Record Enumeration. Top Level Domain (TLD) Expansion. Check for Wildcard Resolution. Brute Force subdomain and host A and AAAA records given a domain and a wordlist. Perform a PTR Record lookup for a given IP Range or CIDR. Check a DNS Server Cached records for A, AAAA and CNAME Records provided a list of host records in a text file to check. Enumerate Common mDNS records in the Local Network Enumerate Hosts and Subdomains using Google. WWW: https://github.com/darkoperator/dnsrecon PR: 208975 Submitted by: Rihaz Jerrin <rihaz.jerrin@gmail.com>
Notes
Notes: svn path=/head/; revision=416092
Diffstat (limited to 'dns/dnsrecon')
-rw-r--r--dns/dnsrecon/Makefile40
-rw-r--r--dns/dnsrecon/distinfo2
-rw-r--r--dns/dnsrecon/pkg-descr17
-rw-r--r--dns/dnsrecon/pkg-plist12
4 files changed, 71 insertions, 0 deletions
diff --git a/dns/dnsrecon/Makefile b/dns/dnsrecon/Makefile
new file mode 100644
index 000000000000..575541472b3c
--- /dev/null
+++ b/dns/dnsrecon/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= dnsrecon
+PORTVERSION= 0.8.9
+DISTVERSIONPREFIX= v
+CATEGORIES= dns
+
+MAINTAINER= rihaz.jerrin@gmail.com
+COMMENT= DNS enumeration tool
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython \
+ ${PYTHON_PKGNAMEPREFIX}netaddr>=0:net/py-netaddr
+
+USE_GITHUB= yes
+GH_ACCOUNT= darkoperator
+
+USES= python:2.7+ shebangfix tar:tgz
+NO_BUILD= yes
+NO_ARCH= yes
+
+SHEBANG_FILES= ${WRKSRC}/dnsrecon.py
+FILELIST= namelist.txt subdomains-top1mil-20000.txt \
+ subdomains-top1mil-5000.txt subdomains-top1mil.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|from lib|from dnsrecon|g' ${WRKSRC}/${PORTNAME}.py
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/dnsrecon
+ (cd ${WRKSRC}/lib && ${COPYTREE_SHARE} \* \
+ ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/dnsrecon)
+ ${INSTALL_SCRIPT} ${WRKSRC}/dnsrecon.py ${STAGEDIR}${PREFIX}/bin/dnsrecon
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/README
+ ${INSTALL_DATA} ${FILELIST:S|^|${WRKSRC}/|} ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/dns/dnsrecon/distinfo b/dns/dnsrecon/distinfo
new file mode 100644
index 000000000000..63ba20e4edd5
--- /dev/null
+++ b/dns/dnsrecon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (darkoperator-dnsrecon-v0.8.9_GH0.tar.gz) = c3b99b423919ed877dd75893212c0365c1491f2abca3de411cee04c467d8500a
+SIZE (darkoperator-dnsrecon-v0.8.9_GH0.tar.gz) = 635161
diff --git a/dns/dnsrecon/pkg-descr b/dns/dnsrecon/pkg-descr
new file mode 100644
index 000000000000..14332dc5c8b0
--- /dev/null
+++ b/dns/dnsrecon/pkg-descr
@@ -0,0 +1,17 @@
+DNSRecon provides the ability to perform:
+
+ Check all NS Records for Zone Transfers.
+ Enumerate General DNS Records for a given
+ Domain (MX, SOA, NS, A, AAAA, SPF and TXT).
+ Perform common SRV Record Enumeration.
+ Top Level Domain (TLD) Expansion.
+ Check for Wildcard Resolution.
+ Brute Force subdomain and host A
+ and AAAA records given a domain and a wordlist.
+ Perform a PTR Record lookup for a given IP Range or CIDR.
+ Check a DNS Server Cached records for A, AAAA and
+ CNAME Records provided a list of host records in a text file to check.
+ Enumerate Common mDNS records in the Local
+ Network Enumerate Hosts and Subdomains using Google.
+
+WWW: https://github.com/darkoperator/dnsrecon
diff --git a/dns/dnsrecon/pkg-plist b/dns/dnsrecon/pkg-plist
new file mode 100644
index 000000000000..b19981c54469
--- /dev/null
+++ b/dns/dnsrecon/pkg-plist
@@ -0,0 +1,12 @@
+bin/dnsrecon
+%%PYTHON_SITELIBDIR%%/dnsrecon/__init__.py
+%%PYTHON_SITELIBDIR%%/dnsrecon/dnshelper.py
+%%PYTHON_SITELIBDIR%%/dnsrecon/gooenum.py
+%%PYTHON_SITELIBDIR%%/dnsrecon/mdnsenum.py
+%%PYTHON_SITELIBDIR%%/dnsrecon/msf_print.py
+%%PYTHON_SITELIBDIR%%/dnsrecon/whois.py
+%%DATADIR%%/namelist.txt
+%%DATADIR%%/subdomains-top1mil-20000.txt
+%%DATADIR%%/subdomains-top1mil-5000.txt
+%%DATADIR%%/subdomains-top1mil.txt
+%%DOCSDIR%%/README