aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsutl
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-27 01:08:35 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-27 01:08:35 +0000
commit63b2ceee1f31ec402f5bcaa2a72bc6575103f86a (patch)
treee131686b49b1abc712a73746f8dfe2607b589d1b /dns/dnsutl
parent7037100c1dea1fd6249446b430c11ef747868fbf (diff)
downloadports-63b2ceee1f31ec402f5bcaa2a72bc6575103f86a.tar.gz
ports-63b2ceee1f31ec402f5bcaa2a72bc6575103f86a.zip
Install manpages and add WWW to DESCR. Note: since our soelim(1) doesn't
support a '-I' argument, instead of this soelim -Iman1 man1/foo.1 > tmp I did this. (cd man1; soelim foo.1) > tmp PR: 15093 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=24123
Diffstat (limited to 'dns/dnsutl')
-rw-r--r--dns/dnsutl/Makefile13
-rw-r--r--dns/dnsutl/files/patch-aa120
-rw-r--r--dns/dnsutl/pkg-descr2
3 files changed, 111 insertions, 24 deletions
diff --git a/dns/dnsutl/Makefile b/dns/dnsutl/Makefile
index 098b9b61c5d0..71c2c57171fd 100644
--- a/dns/dnsutl/Makefile
+++ b/dns/dnsutl/Makefile
@@ -1,7 +1,7 @@
# Ports collection makefile for: dnsutl
# Version required: 1.5
# Date created: Nov 05, 1998
-# Whom: Karl Dietz (Karl.Dietz@triplan.com)
+# Whom: Karl Dietz (Karl.Dietz@frankfurt.netsurf.de)
#
# $FreeBSD$
#
@@ -13,16 +13,13 @@ MASTER_SITES= http://www.canb.auug.org.au/~millerp/dnsutl/ \
http://gd.tuwien.ac.at/softeng/Aegis/dnsutl/ \
ftp://ftp.agso.gov.au/pub/Aegis/dnsutl/
-MAINTAINER= Karl.Dietz@triplan.com
+MAINTAINER= Karl.Dietz@frankfurt.netsurf.de
GNU_CONFIGURE= yes
ALL_TARGET= all sure
-INSTALL_TARGET= install-bin
-# the manpages do need a patched GNU groff 1.11a (use -I for include path)
-#INSTALL_TAGERT+= install-man
-#MAN1= dns-bootp.1 dns-bootparams.1 dns-ethers-import.1 \
-# dns-ethers.1 dns-filter.1 dns-hosts-import.1 \
-# dns-hosts.1 dns-license.1 dns-ng.1 dns-rev.1
+MAN1= dns-bootp.1 dns-bootparams.1 dns-ethers-import.1 \
+ dns-ethers.1 dns-filter.1 dns-hosts-import.1 \
+ dns-hosts.1 dns-license.1 dns-ng.1 dns-rev.1
.include <bsd.port.mk>
diff --git a/dns/dnsutl/files/patch-aa b/dns/dnsutl/files/patch-aa
index 125df082fe6a..14fcc4467082 100644
--- a/dns/dnsutl/files/patch-aa
+++ b/dns/dnsutl/files/patch-aa
@@ -1,16 +1,104 @@
-*** Makefile.in.orig Mon Jul 26 03:49:50 1999
---- Makefile.in Mon Jul 26 03:50:20 1999
-***************
-*** 124,129 ****
---- 124,134 ----
- LIBEXT = a
-
- #
-+ #
-+ #
-+ SOELIM = @SOELIM@
-+
-+ #
- # You should not need to alter anything below this point.
- #------------------------------------------------------------
-
+--- Makefile.in.orig Mon Jul 5 15:54:45 1999
++++ Makefile.in Sun Dec 26 14:40:21 1999
+@@ -124,6 +124,11 @@
+ LIBEXT = a
+
+ #
++#
++#
++SOELIM = @SOELIM@
++
++#
+ # You should not need to alter anything below this point.
+ #------------------------------------------------------------
+
+@@ -594,7 +599,7 @@
+ awk -f etc/txt2c.awk man1/dns-bootp.1 > $@
+
+ $(mandir)/man1/dns-bootp.1: man1/dns-bootp.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-bootp.1 > tmp
++ (cd man1; $(SOELIM) dns-bootp.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -602,7 +607,7 @@
+ awk -f etc/txt2c.awk man1/dns-bootparams.1 > $@
+
+ $(mandir)/man1/dns-bootparams.1: man1/dns-bootparams.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-bootparams.1 > tmp
++ (cd man1; $(SOELIM) dns-bootparams.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -611,7 +616,7 @@
+
+ $(mandir)/man1/dns-ethers-import.1: man1/dns-ethers-import.1 \
+ man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-ethers-import.1 > tmp
++ (cd man1; $(SOELIM) dns-ethers-import.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -619,7 +624,7 @@
+ awk -f etc/txt2c.awk man1/dns-ethers.1 > $@
+
+ $(mandir)/man1/dns-ethers.1: man1/dns-ethers.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-ethers.1 > tmp
++ (cd man1; $(SOELIM) dns-ethers.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -627,7 +632,7 @@
+ awk -f etc/txt2c.awk man1/dns-filter.1 > $@
+
+ $(mandir)/man1/dns-filter.1: man1/dns-filter.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-filter.1 > tmp
++ (cd man1; $(SOELIM) dns-filter.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -635,7 +640,7 @@
+ awk -f etc/txt2c.awk man1/dns-hosts-import.1 > $@
+
+ $(mandir)/man1/dns-hosts-import.1: man1/dns-hosts-import.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-hosts-import.1 > tmp
++ (cd man1; $(SOELIM) dns-hosts-import.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -643,7 +648,7 @@
+ awk -f etc/txt2c.awk man1/dns-hosts.1 > $@
+
+ $(mandir)/man1/dns-hosts.1: man1/dns-hosts.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-hosts.1 > tmp
++ (cd man1; $(SOELIM) dns-hosts.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -651,7 +656,7 @@
+ awk -f etc/txt2c.awk man1/dns-license.1 > $@
+
+ $(mandir)/man1/dns-license.1: man1/dns-license.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-license.1 > tmp
++ (cd man1; $(SOELIM) dns-license.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -659,7 +664,7 @@
+ awk -f etc/txt2c.awk man1/dns-ng.1 > $@
+
+ $(mandir)/man1/dns-ng.1: man1/dns-ng.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-ng.1 > tmp
++ (cd man1; $(SOELIM) dns-ng.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
+@@ -667,7 +672,7 @@
+ awk -f etc/txt2c.awk man1/dns-rev.1 > $@
+
+ $(mandir)/man1/dns-rev.1: man1/dns-rev.1 man1/.mandir
+- $(SOELIM) -Iman1 man1/dns-rev.1 > tmp
++ (cd man1; $(SOELIM) dns-rev.1) > tmp
+ $(INSTALL_DATA) tmp $@
+ @rm tmp
+
diff --git a/dns/dnsutl/pkg-descr b/dns/dnsutl/pkg-descr
index 71950e4d794d..1b3182d70784 100644
--- a/dns/dnsutl/pkg-descr
+++ b/dns/dnsutl/pkg-descr
@@ -16,3 +16,5 @@
All of these programs are both faster than shell scripts,
and more robust when faced with all the peculiar semantics
of DNS resource files.
+
+WWW: http://www.canb.auug.org.au/~millerp/dnsutl/