aboutsummaryrefslogtreecommitdiff
path: root/dns/dsp
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-03-21 20:12:43 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-03-21 20:12:43 +0000
commit522c80dd1ab6ab25180c3f093f3d4aff4e20591c (patch)
treefed7d03bc5d04a9cfea8bde7eb4ba378d24db8e1 /dns/dsp
parent68fa387fbda679cee55b25e4623ac0d1abd8108b (diff)
downloadports-522c80dd1ab6ab25180c3f093f3d4aff4e20591c.tar.gz
ports-522c80dd1ab6ab25180c3f093f3d4aff4e20591c.zip
New port: dns/dsp
DNS Statistics Presenter (DSP) is a tool used for exploring statistics from busy DNS servers collected by DNS Statistics Collector (DSC). WWW: https://www.dns-oarc.net/dsc/ PR: 226630 Submitted by: Leo Vandewoestijne <freebsd@dns.company>
Notes
Notes: svn path=/head/; revision=465236
Diffstat (limited to 'dns/dsp')
-rw-r--r--dns/dsp/Makefile31
-rw-r--r--dns/dsp/distinfo3
-rw-r--r--dns/dsp/pkg-descr5
-rw-r--r--dns/dsp/pkg-plist21
4 files changed, 60 insertions, 0 deletions
diff --git a/dns/dsp/Makefile b/dns/dsp/Makefile
new file mode 100644
index 000000000000..7439bf6a0e0a
--- /dev/null
+++ b/dns/dsp/Makefile
@@ -0,0 +1,31 @@
+# Created by: Leo Vandewoestijne <freebsd@dns.company>
+# $FreeBSD$
+
+PORTNAME= dsp
+PORTVERSION= 2.0.0
+CATEGORIES= dns
+MASTER_SITES= https://www.dns-oarc.net/files/dsc/ \
+ https://dns.company/files/dsc/
+
+MAINTAINER= freebsd@dns.company
+COMMENT= Tool used for collecting and exploring statistics from DNS servers
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= p5-Proc-PID-File>=1.28:devel/p5-Proc-PID-File \
+ p5-XML-Simple>=2.24:textproc/p5-XML-Simple \
+ p5-App-DSC-DataTool>=0.03:dns/p5-App-DSC-DataTool \
+ p5-DSC>=2.04:dns/p5-DSC \
+ p5-CGI>=4.38:www/p5-CGI \
+ p5-Switch>=2.17:lang/p5-Switch \
+ p5-File-Copy-Link>=0.140:devel/p5-File-Copy-Link
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+
+USES= gmake perl5
+PERL5= configure patch shebangfix
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/dns/dsp/distinfo b/dns/dsp/distinfo
new file mode 100644
index 000000000000..485dadcdbb9c
--- /dev/null
+++ b/dns/dsp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520905401
+SHA256 (dsp-2.0.0.tar.gz) = f56e28ebd2f963c1281a5019c7aa89c69d544166f94348d0cec215e567eff7de
+SIZE (dsp-2.0.0.tar.gz) = 148665
diff --git a/dns/dsp/pkg-descr b/dns/dsp/pkg-descr
new file mode 100644
index 000000000000..484eab9fe342
--- /dev/null
+++ b/dns/dsp/pkg-descr
@@ -0,0 +1,5 @@
+DNS Statistics Presenter (DSP) is a tool used
+for exploring statistics from busy DNS servers
+collected by DNS Statistics Collector (DSC).
+
+WWW: https://www.dns-oarc.net/dsc/
diff --git a/dns/dsp/pkg-plist b/dns/dsp/pkg-plist
new file mode 100644
index 000000000000..025c5a1a69f9
--- /dev/null
+++ b/dns/dsp/pkg-plist
@@ -0,0 +1,21 @@
+%%ETCDIR%%/dsc-grapher.cfg.sample
+lib/cgi-bin/dsc-grapher.pl
+lib/cgi-bin/put-file.pl
+libexec/dsp/dsc-grapher-cli.pl
+libexec/dsp/dsc-xml-extractor.pl
+libexec/dsp/fix-corrupted-dat-files.pl
+libexec/dsp/refile-and-grok.sh
+libexec/dsp/remove-xmls.pl
+libexec/dsp/update-dat-file-locations.sh
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%DATADIR%%/html/1downarrow.png
+%%DATADIR%%/html/1leftarrow.png
+%%DATADIR%%/html/1rightarrow.png
+%%DATADIR%%/html/1uparrow.png
+%%DATADIR%%/html/2downarrow.png
+%%DATADIR%%/html/2leftarrow.png
+%%DATADIR%%/html/2rightarrow.png
+%%DATADIR%%/html/2uparrow.png
+%%DATADIR%%/html/plot.page