aboutsummaryrefslogtreecommitdiff
path: root/dns/dynip
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2017-12-14 17:08:01 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2017-12-14 17:08:01 +0000
commit611e9b36dda5b11a86986cf79a042f96b52a55c0 (patch)
tree568af5b275317acbcbb120fc8341446cb14a84e8 /dns/dynip
parentacad63c2637f9c7fcee7dc6cfe2e771f6f275eac (diff)
downloadports-611e9b36dda5b11a86986cf79a042f96b52a55c0.tar.gz
ports-611e9b36dda5b11a86986cf79a042f96b52a55c0.zip
Notes
Diffstat (limited to 'dns/dynip')
-rw-r--r--dns/dynip/Makefile32
-rw-r--r--dns/dynip/distinfo3
-rw-r--r--dns/dynip/pkg-descr29
-rw-r--r--dns/dynip/pkg-message9
-rw-r--r--dns/dynip/pkg-plist4
5 files changed, 77 insertions, 0 deletions
diff --git a/dns/dynip/Makefile b/dns/dynip/Makefile
new file mode 100644
index 000000000000..369d58e8da10
--- /dev/null
+++ b/dns/dynip/Makefile
@@ -0,0 +1,32 @@
+# Created by: Joe Barbish
+# $FreeBSD$
+
+PORTNAME= dynip
+PORTVERSION= 0.0
+CATEGORIES= dns
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= dynip@a1poweruser.com
+COMMENT= Dynamic IP Address Updater
+
+LICENSE= BSD2CLAUSE
+
+USES= tar:bzip2
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dynip \
+ ${STAGEDIR}${PREFIX}/bin
+
+ ${INSTALL_SCRIPT} ${WRKSRC}/dynip_rcd \
+ ${STAGEDIR}${PREFIX}/etc/rc.d/dynip
+
+ ${INSTALL_MAN} ${WRKSRC}/dynip.8 \
+ ${STAGEDIR}${MAN8PREFIX}/man/man8
+
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
+ ${INSTALL_SCRIPT} ${WRKSRC}/dynip_daily \
+ ${STAGEDIR}${PREFIX}/etc/periodic/daily/dynip
+
+.include <bsd.port.mk>
diff --git a/dns/dynip/distinfo b/dns/dynip/distinfo
new file mode 100644
index 000000000000..60e6f03c7cb0
--- /dev/null
+++ b/dns/dynip/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511635168
+SHA256 (dynip-0.0.tar.bz2) = 323cc11b367b04027741cbcfcad6b9af45e3cc9ca1dffe1b36b4b29c42fd297b
+SIZE (dynip-0.0.tar.bz2) = 5057
diff --git a/dns/dynip/pkg-descr b/dns/dynip/pkg-descr
new file mode 100644
index 000000000000..791650c896de
--- /dev/null
+++ b/dns/dynip/pkg-descr
@@ -0,0 +1,29 @@
+dynip is a daemon that monitors your host system ISP assigned dynamic IP
+address. If it changes, dynip automatically updates the dynamic DNS IP
+address at your dynamic DNS hosting provider then posts an informational
+message to the host system log followed by sending an informational email
+to user root.
+
+The dynip daemon and the daily script are very simple Bourne Shell type
+scripts containing self documenting embedded comments. They use the
+"fetch" command to issue the standard browser style URL format used by
+most dynamic DNS hosting providers for the purpose of actual updating
+the registered IP address with the new IP address. There are some small
+variations in the URL format depending on the dynamic DNS hosting
+provider being used.
+
+Mandatory requirements. The host that is running dynip "MUST" be cabled
+directly to the ISP modem and be using the public routable dynamic IP
+address assigned by the ISP.
+
+Includes templates for these dynamic DNS hosting providers
+ namecheap.com
+ freedns.afraid.org
+ changeip.com
+ no-ip.com
+ zoneedit.com
+ easydns.com
+and is simple to configure for other providers that use a variation
+of the URL format.
+
+WWW: http://dynip.sourceforge.net/
diff --git a/dns/dynip/pkg-message b/dns/dynip/pkg-message
new file mode 100644
index 000000000000..89aec54092d9
--- /dev/null
+++ b/dns/dynip/pkg-message
@@ -0,0 +1,9 @@
+########################################################################
+
+ dynip
+
+ Dynamic IP Address Updater
+
+ Issue "man dynip" For set up and usage information
+
+########################################################################
diff --git a/dns/dynip/pkg-plist b/dns/dynip/pkg-plist
new file mode 100644
index 000000000000..2c2aa34bc56a
--- /dev/null
+++ b/dns/dynip/pkg-plist
@@ -0,0 +1,4 @@
+bin/dynip
+etc/rc.d/dynip
+etc/periodic/daily/dynip
+man/man8/dynip.8.gz