aboutsummaryrefslogtreecommitdiff
path: root/dns/fpdns
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-07-03 14:23:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-07-03 14:23:35 +0000
commita2f9c950793bb7f8cec162fdf61ab27257c9676b (patch)
tree541dbfb4aba5c155e44ef41777e0fc4ef888fade /dns/fpdns
parent9448cc82dee36a3fd9a27727a88f2dc56467d348 (diff)
downloadports-a2f9c950793bb7f8cec162fdf61ab27257c9676b.tar.gz
ports-a2f9c950793bb7f8cec162fdf61ab27257c9676b.zip
fpdns - Fingerprinting DNS servers
Identify what versions of nameserver software is running. WWW: http://www.rfc.se/fpdns/
Notes
Notes: svn path=/head/; revision=112852
Diffstat (limited to 'dns/fpdns')
-rw-r--r--dns/fpdns/Makefile34
-rw-r--r--dns/fpdns/distinfo2
-rw-r--r--dns/fpdns/files/patch-fpdns.pl10
-rw-r--r--dns/fpdns/pkg-descr23
-rw-r--r--dns/fpdns/pkg-plist1
5 files changed, 70 insertions, 0 deletions
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
new file mode 100644
index 000000000000..fdfcef228308
--- /dev/null
+++ b/dns/fpdns/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fpdns
+# Date Created: July 2 2004
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpdns
+PORTVERSION= 0.9.0
+CATEGORIES= dns
+MASTER_SITES= http://www.rfc.se/fpdns/distfiles/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.gz
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= FPDNS - Fingerprinting DNS servers
+
+WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Requires at least Perl version 5.6.0"
+.endif
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${GZCAT} ${DISTDIR}/${DISTFILES} > ${WRKDIR}/fpdns.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/fpdns.pl ${PREFIX}/bin/fpdns
+
+.include <bsd.port.post.mk>
diff --git a/dns/fpdns/distinfo b/dns/fpdns/distinfo
new file mode 100644
index 000000000000..8d635435ef0c
--- /dev/null
+++ b/dns/fpdns/distinfo
@@ -0,0 +1,2 @@
+MD5 (fpdns-0.9.0.gz) = 03c351915aaa654e6dcaa61a69783477
+SIZE (fpdns-0.9.0.gz) = 5393
diff --git a/dns/fpdns/files/patch-fpdns.pl b/dns/fpdns/files/patch-fpdns.pl
new file mode 100644
index 000000000000..80c36846737b
--- /dev/null
+++ b/dns/fpdns/files/patch-fpdns.pl
@@ -0,0 +1,10 @@
+--- fpdns.pl.orig Sun Jul 4 00:21:01 2004
++++ fpdns.pl Sun Jul 4 00:21:33 2004
+@@ -461,6 +461,7 @@
+ -t time (set query timeout) [5]
+ -v (show version)
+
++See http://www.rfc.se/fpdns/ for more information about $progname.
+ EOF
+ exit 2;
+
diff --git a/dns/fpdns/pkg-descr b/dns/fpdns/pkg-descr
new file mode 100644
index 000000000000..6fc344742c70
--- /dev/null
+++ b/dns/fpdns/pkg-descr
@@ -0,0 +1,23 @@
+fpdns - Fingerprinting DNS servers
+
+A nameserver basically responds to a query. Interoperability is an
+obvious requirement here. The standard protocol behaviour of different
+DNS implementations is expected to be the same.
+
+Requirements for protocol behaviour of DNS implementations is widely
+documented in the case of 'common' dns messages. The DNS protocol
+is over 20 years old and since its inception, there have been over
+40 independent DNS implementations, while some implementations have
+over 20 versions.
+
+The methodology used to identify individual nameserver implementations
+is based on "borderline" protocol behaviour. The DNS protocol offers
+a multitude of message bits, response types, opcodes, classes, query
+types and label types in a fashion that makes some mutually exclusive
+while some are not used in a query messages at all. Not every
+implementation offers the full set of features the DNS protocol set
+currently has. Some implementations offer features outside the
+protocol set, and there are implementations that do not conform to
+standards.
+
+WWW: http://www.rfc.se/fpdns/
diff --git a/dns/fpdns/pkg-plist b/dns/fpdns/pkg-plist
new file mode 100644
index 000000000000..85ad4b6b67c0
--- /dev/null
+++ b/dns/fpdns/pkg-plist
@@ -0,0 +1 @@
+bin/fpdns