aboutsummaryrefslogtreecommitdiff
path: root/dns/gdnsd2
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-11-23 21:35:00 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-11-23 21:35:00 +0000
commite67ac74f414bd66d5b4654d677a2068fd6a04e13 (patch)
tree6916983384915300331301bf85e185be92c112bc /dns/gdnsd2
parent3cc803de7b086e777fd86e78b197dd3b61fadcb3 (diff)
downloadports-e67ac74f414bd66d5b4654d677a2068fd6a04e13.tar.gz
ports-e67ac74f414bd66d5b4654d677a2068fd6a04e13.zip
- Add libmaxminddb for geoip2 support
- Bump PORTREVISION PR: 223814 Submitted by: peter@
Notes
Notes: svn path=/head/; revision=454804
Diffstat (limited to 'dns/gdnsd2')
-rw-r--r--dns/gdnsd2/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/dns/gdnsd2/Makefile b/dns/gdnsd2/Makefile
index aca6a44668a8..0eb775f953c1 100644
--- a/dns/gdnsd2/Makefile
+++ b/dns/gdnsd2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdnsd
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= https://github.com/gdnsd/gdnsd/releases/download/v${PORTVERSION}/ \
ZI \
@@ -34,11 +34,18 @@ USE_RC_SUBR= gdnsd
USERS?= gdnsd
GROUPS?= gdnsd
-OPTIONS_DEFINE= DOCS GEOIP URCU
-OPTIONS_DEFAULT=GEOIP
+OPTIONS_DEFINE= DOCS URCU
+OPTIONS_DEFAULT=MAXMINDDB
-GEOIP_DESC= Enable GeoIP Support
-GEOIP_RUN_DEPENDS= GeoIP>=0:net/GeoIP
+OPTIONS_RADIO= GEOLIB
+OPTIONS_RADIO_GEOLIB= GEOIP MAXMINDDB
+GEOLIB_DESC= GeoIP backend
+
+GEOIP_DESC= Enable GeoIP1 Support
+GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+
+MAXMINDDB_DESC= Enable GeoIP1 + GeoIP2 Support
+MAXMINDDB_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
URCU_DESC= Read-Copy-Update Support (Faster Zone Parsing)
URCU_CONFIGURE_WITH= urcu