aboutsummaryrefslogtreecommitdiff
path: root/dns/gdnsd3
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2020-09-30 16:35:50 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2020-09-30 16:35:50 +0000
commit078a3eaa73fb9c7f849dd35665bf979e5eaf23b3 (patch)
treef21e1a4cb1601930be29c60859e5f2d5775fb3cc /dns/gdnsd3
parent0cfd7ac66a26a0d56e0b3fffc669a69545f07cd7 (diff)
downloadports-078a3eaa73fb9c7f849dd35665bf979e5eaf23b3.tar.gz
ports-078a3eaa73fb9c7f849dd35665bf979e5eaf23b3.zip
- Update to 3.3.0
Notes
Notes: svn path=/head/; revision=550721
Diffstat (limited to 'dns/gdnsd3')
-rw-r--r--dns/gdnsd3/Makefile7
-rw-r--r--dns/gdnsd3/distinfo6
-rw-r--r--dns/gdnsd3/files/patch-src_css.c13
3 files changed, 21 insertions, 5 deletions
diff --git a/dns/gdnsd3/Makefile b/dns/gdnsd3/Makefile
index 9769272b9559..5a19c7c67ec2 100644
--- a/dns/gdnsd3/Makefile
+++ b/dns/gdnsd3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gdnsd
-PORTVERSION= 3.0.0
-PORTREVISION= 1
+PORTVERSION= 3.3.0
CATEGORIES= dns
MASTER_SITES= https://github.com/gdnsd/gdnsd/releases/download/v${PORTVERSION}/ \
ZI \
@@ -49,6 +48,10 @@ CFLAGS+= -fstack-protector-strong -fexceptions -ftrapv
LDFLAGS+= -Wl,-z,relro -Wl,-z,now -Wl,-z,noexecstack
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's|-Wall |-Wall -Wno-unused-variable |g' \
+ ${WRKSRC}/Makefile
+
post-patch:
@${REINPLACE_CMD} -e 's|$${localstatedir}/lib/$${PACKAGE_NAME}|/var/db/${PORTNAME}|g' \
${WRKSRC}/configure
diff --git a/dns/gdnsd3/distinfo b/dns/gdnsd3/distinfo
index 31a8c76237d8..c638d622d6b9 100644
--- a/dns/gdnsd3/distinfo
+++ b/dns/gdnsd3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550849201
-SHA256 (gdnsd-3.0.0.tar.xz) = e08bf1c0d76bd6cecffd9e0da351f7983e6d25c9ace74b7c28f45fe39e3f389e
-SIZE (gdnsd-3.0.0.tar.xz) = 451776
+TIMESTAMP = 1601481834
+SHA256 (gdnsd-3.3.0.tar.xz) = 0b167cc218b727ff959ae03e019f6d9518bac99bdccf2f397997ee5b0ac146d6
+SIZE (gdnsd-3.3.0.tar.xz) = 466844
diff --git a/dns/gdnsd3/files/patch-src_css.c b/dns/gdnsd3/files/patch-src_css.c
new file mode 100644
index 000000000000..64cf2555a777
--- /dev/null
+++ b/dns/gdnsd3/files/patch-src_css.c
@@ -0,0 +1,13 @@
+--- src/css.c.orig 2020-09-30 16:32:21 UTC
++++ src/css.c
+@@ -51,6 +51,10 @@
+ #include <netinet/ip.h>
+ #include <netinet/tcp.h>
+
++#ifndef SOL_TCP
++#define SOL_TCP IPPROTO_TCP
++#endif
++
+ // makes sides of int[] from pipe2() clearer
+ #define PIPE_RD 0
+ #define PIPE_WR 1