aboutsummaryrefslogtreecommitdiff
path: root/dns/hesiod
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-10 20:56:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-10 20:56:24 +0000
commit9143d2efab7351e7a57253f0700e04d2f7fb1b23 (patch)
tree4e18169cf9dcbb4980bfcda170e2719f970cee92 /dns/hesiod
parent3394f6d3063f0a0a59e7273b67fcf85b5ed3b151 (diff)
downloadports-9143d2efab7351e7a57253f0700e04d2f7fb1b23.tar.gz
ports-9143d2efab7351e7a57253f0700e04d2f7fb1b23.zip
- Update to 3.1.0
- Pass maintainership to submitter PR: ports/101601 Submitted by: Stanislav Sedov <ssedov(at)mbsd.msk.ru> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=170308
Diffstat (limited to 'dns/hesiod')
-rw-r--r--dns/hesiod/Makefile28
-rw-r--r--dns/hesiod/distinfo6
-rw-r--r--dns/hesiod/files/patch-aa52
-rw-r--r--dns/hesiod/pkg-plist4
4 files changed, 16 insertions, 74 deletions
diff --git a/dns/hesiod/Makefile b/dns/hesiod/Makefile
index daed6c196cf9..c10d671d17f8 100644
--- a/dns/hesiod/Makefile
+++ b/dns/hesiod/Makefile
@@ -6,35 +6,29 @@
#
PORTNAME= hesiod
-PORTVERSION= 3.0.2
+PORTVERSION= 3.1.0
CATEGORIES= dns
MASTER_SITES= ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= A directory service built on DNS and BIND
-MAN1= hesinfo.1
MAN3= hesiod.3 hesiod_end.3 hesiod_free_list.3 \
hesiod_free_passwd.3 hesiod_free_postoffice.3 \
hesiod_free_servent.3 hesiod_getmailhost.3 \
hesiod_getpwnam.3 hesiod_getpwuid.3 \
hesiod_getservbyname.3 hesiod_init.3 \
- hesiod_resolve.3 hesiod_to_bind.3
+ hesiod_resolve.3 hesiod_to_bind.3 \
+ hesiod_free_string.3 hesiod_parse_result.3
MAN5= hesiod.conf.5
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e "s,\$${INSTALL} -m 444,\$${BSD_INSTALL_MAN}," \
+ -e "s,\$${INSTALL} -m 644,\$${BSD_INSTALL_DATA}," \
+ ${WRKSRC}/Makefile.in
-.if ${PORTOBJFORMAT} == elf
-VERSION=3
-SONAME="-Wl,-soname,libhesiod.so.${VERSION}"
-.else
-VERSION=3.0
-.endif
-
-MAKE_ENV+= VERSION="${VERSION}" SONAME="${SONAME}"
-CFLAGS+= -fPIC
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/hesiod/distinfo b/dns/hesiod/distinfo
index 8129ffde93bf..32f60e49b60b 100644
--- a/dns/hesiod/distinfo
+++ b/dns/hesiod/distinfo
@@ -1,3 +1,3 @@
-MD5 (hesiod-3.0.2.tar.gz) = 0362311e80fb1e029a1588cbbd09ad57
-SHA256 (hesiod-3.0.2.tar.gz) = ee0ff39ad2445728360e1550de3c18d48813b3f9359ea3ad8a49f71ffb314c25
-SIZE (hesiod-3.0.2.tar.gz) = 31974
+MD5 (hesiod-3.1.0.tar.gz) = 89c785d350e75d6628754659ee4583e8
+SHA256 (hesiod-3.1.0.tar.gz) = 57b288ea736614d630677da7b6fa3f46c6b07a0ec7e798860f318e887e2602b6
+SIZE (hesiod-3.1.0.tar.gz) = 224294
diff --git a/dns/hesiod/files/patch-aa b/dns/hesiod/files/patch-aa
deleted file mode 100644
index 3dcb8dfc6155..000000000000
--- a/dns/hesiod/files/patch-aa
+++ /dev/null
@@ -1,52 +0,0 @@
---- Makefile.in.orig Fri Jan 3 15:02:55 1997
-+++ Makefile.in Mon Oct 4 12:29:32 1999
-@@ -24,17 +24,24 @@
- ALL_CFLAGS=-I. -DSYSCONFDIR=\"${sysconfdir}\" ${CPPFLAGS} ${CFLAGS}
- OBJS=hesiod.o hesmailhost.o hespwnam.o hesservbyname.o hescompat.o
-
--all: libhesiod.a hesinfo hestest
-+all: libhesiod.so.${VERSION} libhesiod.so hesinfo hestest libhesiod.a
-
- libhesiod.a: ${OBJS}
- ar cru $@ ${OBJS}
- ${RANLIB} $@
-
--hesinfo: hesinfo.o libhesiod.a
-- ${CC} ${LDFLAGS} -o $@ hesinfo.o libhesiod.a ${LIBS}
-+libhesiod.so.${VERSION}: ${OBJS}
-+ ${CC} -shared ${LDFLAGS} ${SONAME} ${OBJS} -o $@
-
--hestest: hestest.o libhesiod.a
-- ${CC} ${LDFLAGS} -o $@ hestest.o libhesiod.a ${LIBS}
-+libhesiod.so: libhesiod.so.${VERSION}
-+ rm -f $@
-+ ln $> $@
-+
-+hesinfo: hesinfo.o ${SHLIB}
-+ ${CC} ${LDFLAGS} -o $@ hesinfo.o -L. -lhesiod ${LIBS}
-+
-+hestest: hestest.o ${SHLIB}
-+ ${CC} ${LDFLAGS} -o $@ hestest.o -L. -lhesiod ${LIBS}
-
- ${OBJS}: hesiod.h resscan.h
-
-@@ -55,6 +62,9 @@
- ${INSTALL} -c -m 644 libhesiod.a ${DESTDIR}${libdir}
- ${RANLIB} ${DESTDIR}${libdir}/libhesiod.a
- chmod u-w ${DESTDIR}${libdir}/libhesiod.a
-+ ${INSTALL} -c -m 444 libhesiod.so.${VERSION} ${DESTDIR}${libdir}
-+ ln -f -s ${DESTDIR}${libdir}/libhesiod.so.${VERSION} \
-+ ${DESTDIR}${libdir}/libhesiod.so
- ${INSTALL_PROGRAM} -c -m 555 hesinfo ${DESTDIR}${lbindir}
- ${INSTALL} -c -m 444 ${srcdir}/hesiod.h ${DESTDIR}${includedir}
- ${INSTALL} -c -m 444 ${srcdir}/hesinfo.1 ${DESTDIR}${mandir}/man1
-@@ -85,7 +95,8 @@
- ${INSTALL} -c -m 444 ${srcdir}/hesiod.conf.5 ${DESTDIR}${mandir}/man5
-
- clean:
-- rm -f ${OBJS} libhesiod.a hesinfo.o hesinfo hestest.o hestest
-+ rm -f ${OBJS} libhesiod.a hesinfo.o hesinfo hestest.o hestest \
-+ libhesiod.so.3
-
- distclean: clean
- rm -f config.cache config.log config.status Makefile config.h
diff --git a/dns/hesiod/pkg-plist b/dns/hesiod/pkg-plist
index 04cc9777a7e5..163f2e043ac3 100644
--- a/dns/hesiod/pkg-plist
+++ b/dns/hesiod/pkg-plist
@@ -1,5 +1,5 @@
-bin/hesinfo
include/hesiod.h
lib/libhesiod.a
+lib/libhesiod.la
lib/libhesiod.so
-lib/libhesiod.so.3.0
+lib/libhesiod.so.0