aboutsummaryrefslogtreecommitdiff
path: root/dns/hesiod
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-26 06:33:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-26 06:33:30 +0000
commit956abc081bba4ff15e912d0021be2a47466187ec (patch)
tree945c2d063176d49f80d4072bc9595be8e076ebfa /dns/hesiod
parente5d313c75b5f194e2bc98b991adf301a2f144068 (diff)
downloadports-956abc081bba4ff15e912d0021be2a47466187ec.tar.gz
ports-956abc081bba4ff15e912d0021be2a47466187ec.zip
- Update to 3.2.1
PR: 177910 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=316571
Diffstat (limited to 'dns/hesiod')
-rw-r--r--dns/hesiod/Makefile63
-rw-r--r--dns/hesiod/distinfo4
-rw-r--r--dns/hesiod/files/patch-hestest.c12
-rw-r--r--dns/hesiod/pkg-plist2
4 files changed, 40 insertions, 41 deletions
diff --git a/dns/hesiod/Makefile b/dns/hesiod/Makefile
index dbc20e7f2d43..6865531e8c5e 100644
--- a/dns/hesiod/Makefile
+++ b/dns/hesiod/Makefile
@@ -1,35 +1,44 @@
-# Ports collection Makefile for: Hesiod
-# Date created: 6/11/1998
-# Whom: n@nectar.com
-#
+# Created by: n@nectar.com
# $FreeBSD$
-#
-PORTNAME= hesiod
-PORTVERSION= 3.1.0
-CATEGORIES= dns
-MASTER_SITES= ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/
+PORTNAME= hesiod
+PORTVERSION= 3.2.1
+CATEGORIES= dns
+MASTER_SITES= ftp://athena-dist.mit.edu/pub/ATHENA/hesiod/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A directory service built on DNS and BIND
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Directory service built on DNS and BIND
-MAN3= hesiod.3 hesiod_end.3 hesiod_free_list.3 \
- hesiod_free_passwd.3 hesiod_free_postoffice.3 \
- hesiod_free_servent.3 hesiod_getmailhost.3 \
- hesiod_getpwnam.3 hesiod_getpwuid.3 \
- hesiod_getservbyname.3 hesiod_init.3 \
- hesiod_resolve.3 hesiod_to_bind.3 \
- hesiod_free_string.3 hesiod_parse_result.3
-MAN5= hesiod.conf.5
+LICENSE= BSD
+OPTIONS_DEFINE= IDN
+OPTIONS_DEFAULT=IDN
+
+USES= pathfix
USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s,\$${INSTALL} -m 444,\$${BSD_INSTALL_MAN}," \
- -e "s,\$${INSTALL} -m 644,\$${BSD_INSTALL_DATA}," \
- ${WRKSRC}/Makefile.in
+CONFIGURE_ARGS= --disable-silent-rules
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAN1= hesinfo.1
+MAN3= hesiod.3 hesiod_end.3 hesiod_free_list.3 \
+ hesiod_free_passwd.3 hesiod_free_postoffice.3 \
+ hesiod_free_servent.3 hesiod_getmailhost.3 \
+ hesiod_getpwnam.3 hesiod_getpwuid.3 \
+ hesiod_getservbyname.3 hesiod_init.3 \
+ hesiod_resolve.3 hesiod_to_bind.3 \
+ hesiod_free_string.3 hesiod_parse_result.3
+MAN5= hesiod.conf.5
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIDN}
+LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+.else
+CONFIGURE_ARGS+=--without-libidn
+.endif
.include <bsd.port.mk>
diff --git a/dns/hesiod/distinfo b/dns/hesiod/distinfo
index 10ea79f7d97a..8e6aa23093e8 100644
--- a/dns/hesiod/distinfo
+++ b/dns/hesiod/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hesiod-3.1.0.tar.gz) = 57b288ea736614d630677da7b6fa3f46c6b07a0ec7e798860f318e887e2602b6
-SIZE (hesiod-3.1.0.tar.gz) = 224294
+SHA256 (hesiod-3.2.1.tar.gz) = bad72fcd1761601eee244153739c8829c71dcc30dd33300f5111a9a9ed5b4076
+SIZE (hesiod-3.2.1.tar.gz) = 368075
diff --git a/dns/hesiod/files/patch-hestest.c b/dns/hesiod/files/patch-hestest.c
deleted file mode 100644
index e8a4122473b8..000000000000
--- a/dns/hesiod/files/patch-hestest.c
+++ /dev/null
@@ -1,12 +0,0 @@
-*** hestest.c.orig Sat Sep 7 10:33:20 2002
---- hestest.c Sat Sep 7 10:33:26 2002
-***************
-*** 24,29 ****
---- 24,30 ----
- #include <netdb.h>
- #include <errno.h>
- #include <pwd.h>
-+ #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <stdarg.h>
diff --git a/dns/hesiod/pkg-plist b/dns/hesiod/pkg-plist
index 163f2e043ac3..d3e7fa091b42 100644
--- a/dns/hesiod/pkg-plist
+++ b/dns/hesiod/pkg-plist
@@ -1,5 +1,7 @@
+bin/hesinfo
include/hesiod.h
lib/libhesiod.a
lib/libhesiod.la
lib/libhesiod.so
lib/libhesiod.so.0
+libdata/pkgconfig/hesiod.pc