aboutsummaryrefslogtreecommitdiff
path: root/dns/hostdb
diff options
context:
space:
mode:
authorCraig Rodrigues <rodrigc@FreeBSD.org>2013-07-16 20:35:20 +0000
committerCraig Rodrigues <rodrigc@FreeBSD.org>2013-07-16 20:35:20 +0000
commitd4ba53c21b0562e38efb63ad24e759affc801801 (patch)
tree26d16bd76455da54eaf6174a167ceb1260e86c81 /dns/hostdb
parent95f72837be3f9b66605159c29d88dbf7626c764c (diff)
downloadports-d4ba53c21b0562e38efb63ad24e759affc801801.tar.gz
ports-d4ba53c21b0562e38efb63ad24e759affc801801.zip
Notes
Diffstat (limited to 'dns/hostdb')
-rw-r--r--dns/hostdb/Makefile35
-rw-r--r--dns/hostdb/distinfo2
-rw-r--r--dns/hostdb/files/patch-bin.diff33
-rw-r--r--dns/hostdb/pkg-descr10
-rw-r--r--dns/hostdb/pkg-plist90
5 files changed, 170 insertions, 0 deletions
diff --git a/dns/hostdb/Makefile b/dns/hostdb/Makefile
new file mode 100644
index 000000000000..43fc86e01b91
--- /dev/null
+++ b/dns/hostdb/Makefile
@@ -0,0 +1,35 @@
+# Created by: rodrigc@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= hostdb
+PORTVERSION= 1.004
+CATEGORIES= dns
+MASTER_SITES= GOOGLE_CODE
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= rodrigc@FreeBSD.org
+COMMENT= Generate DNS and DHCP config files from single source
+
+NO_BUILD= yes
+
+HOSTDB_EXAMPLES_DIRS= example1/out example1/ example2 hiddenmaster
+HOSTDB_EXAMPLES_DIRS+= mailserverexample/out mailserverexample
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${PREFIX}/bin
+.if ${PORT_OPTIONS:MEXAMPLES}
+.for dir in ${HOSTDB_EXAMPLES_DIRS}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/
+.endfor
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/hostdb/distinfo b/dns/hostdb/distinfo
new file mode 100644
index 000000000000..33adff7bc7f7
--- /dev/null
+++ b/dns/hostdb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hostdb-1.004.tgz) = beea7cfcdc384eb40d0bc8b3ad2eb094ee81ca75e8eef7c07ea4a47e9f0da350
+SIZE (hostdb-1.004.tgz) = 164585
diff --git a/dns/hostdb/files/patch-bin.diff b/dns/hostdb/files/patch-bin.diff
new file mode 100644
index 000000000000..96b5c1fc20f9
--- /dev/null
+++ b/dns/hostdb/files/patch-bin.diff
@@ -0,0 +1,33 @@
+--- bin/NIdhcpupdate.orig 2006-07-09 19:11:52.000000000 -0700
++++ bin/NIdhcpupdate 2013-07-15 23:39:08.368673247 -0700
+@@ -1,4 +1,4 @@
+-#! /bin/bash
++#!/bin/sh
+
+
+ # Copyright 2005 Thomas A. Limoncelli
+@@ -18,7 +18,7 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+
+
+-function usage
++usage
+ {
+ echo "
+ Usage:
+--- bin/sortbyip.orig 2013-07-15 23:40:10.298670968 -0700
++++ bin/sortbyip 2013-07-15 23:40:23.308670176 -0700
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # Sort by IP address. Assume IP address is at front of line.
+ # Options:
+--- bin/zone2hostdb.orig 2013-07-15 23:40:14.308673854 -0700
++++ bin/zone2hostdb 2013-07-15 23:40:27.638673094 -0700
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # Takes a zonefile and converts it to a rough estimate
+ # of what hostdb.txt should be.
diff --git a/dns/hostdb/pkg-descr b/dns/hostdb/pkg-descr
new file mode 100644
index 000000000000..ed080a91d3bb
--- /dev/null
+++ b/dns/hostdb/pkg-descr
@@ -0,0 +1,10 @@
+HostDB is a system for generating internal DNS zones, external DNS zones,
+and DHCP configuration data from the same hostlist.txt file.
+Keep your configurations consistent by generating them all from the same
+source.
+
+A system for generating internal DNS zones, external DNS zones, and
+DHCP configuration data from the same simple repository.
+
+WWW: http://code.google.com/p/hostdb
+ http://everythingsysadmin.com/hostdb
diff --git a/dns/hostdb/pkg-plist b/dns/hostdb/pkg-plist
new file mode 100644
index 000000000000..42b371ed4538
--- /dev/null
+++ b/dns/hostdb/pkg-plist
@@ -0,0 +1,90 @@
+bin/Example_comparezones
+bin/NIdhcpupdate
+bin/canonzone
+bin/catif
+bin/checkrootcache
+bin/copy-if-change
+bin/genrange
+bin/mergeiplists
+bin/mkdestinations
+bin/mknamedconf
+bin/mkzones
+bin/sortbyip
+bin/zone2hostdb
+bin/zone2hostdbhelper
+%%PORTDOCS%%%%DOCSDIR%%/hostdb-options.txt
+%%PORTDOCS%%%%DOCSDIR%%/lisa2005-paper.pdf
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/zoneconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/dhcpd.conf-tail
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/hostdb-ranges2.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/stage1.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/INTERNAL.named.conf-tail
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/EXTERNAL.named.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/destinations.mk
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/serial
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/INTERNAL.example.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/EXTERNAL.example.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/EXTERNAL.named.root.new
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/INTERNAL.179.32.64.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/dhcpd.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/EXTERNAL.named.root
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/x
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/INTERNAL.named.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/INTERNAL.1.1.10.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/SLAVE.named.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/out/EXTERNAL.179.32.64.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/hostdb-original.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/destinations.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/hostdb.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/dhcpd.conf-head
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/hostdb-ranges.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/INTERNAL.named.conf-head
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/hostdb.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/localhost.zone
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/dhcpd.conf-head
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/named.local
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/dhcpd.conf-tail
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/zoneconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/goodstart/destinations.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/stage1.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/hostdb.txt-enum
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/hostdb.txt-base
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/240.1.10.in-addr.arpa.originalzone
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/cibernet.com-originalzone
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/hostdb.txt-draft
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.16.113.212.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.151.80.66.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/INTERNAL.example.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.example.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.6.113.212.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.100.134.66.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/INTERNAL.240.1.10.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/INTERNAL.87.195.193.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/INTERNAL.cibernet.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/serial
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.cibernet.com
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.87.195.193.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/INTERNAL.1.168.192.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/INTERNAL.201.1.10.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/out/EXTERNAL.166.155.66.in-addr.arpa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/hostdb.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailserverexample/zoneconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiddenmaster/EXTERNAL.named.root.new
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiddenmaster/zoneconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiddenmaster/EXTERNAL.named.root
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiddenmaster/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiddenmaster/hostdb.txt
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/example1/out
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/example1
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/example2
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/goodstart
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/hiddenmaster
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/mailserverexample/out
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/mailserverexample
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%