aboutsummaryrefslogtreecommitdiff
path: root/dns/knot2/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2015-05-18 11:33:11 +0000
committerErwin Lansing <erwin@FreeBSD.org>2015-05-18 11:33:11 +0000
commit61fb20e769377ce8fac34b222f2f218fb150d078 (patch)
tree5480b93c01ac416bc1e44401a9cf7ade363390b4 /dns/knot2/Makefile
parent21c81c17640c6e0c76203a8915c333ca8423b405 (diff)
downloadports-61fb20e769377ce8fac34b222f2f218fb150d078.tar.gz
ports-61fb20e769377ce8fac34b222f2f218fb150d078.zip
Notes
Diffstat (limited to 'dns/knot2/Makefile')
-rw-r--r--dns/knot2/Makefile73
1 files changed, 73 insertions, 0 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
new file mode 100644
index 000000000000..2a9ab2f7462e
--- /dev/null
+++ b/dns/knot2/Makefile
@@ -0,0 +1,73 @@
+# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
+# $FreeBSD$
+
+PORTNAME= knot
+DISTVERSION= 2.0.0-beta
+CATEGORIES= dns ipv6
+MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
+ http://dns-lab.com/downloads/knot-dns/
+PKGNAMESUFFIX= 2
+
+MAINTAINER= freebsd@dns-lab.com
+COMMENT= High performance authoritative-only DNS server
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libjansson.so:${PORTSDIR}/devel/jansson \
+ liblmdb.so:${PORTSDIR}/databases/lmdb \
+ libnettle.so:${PORTSDIR}/security/nettle \
+ liburcu.so:${PORTSDIR}/sysutils/liburcu
+
+CONFLICTS= knot-1.* knot1-[0-6].*
+
+USES= alias libtool pkgconfig tar:xz
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-rundir=/var/run/knot \
+ --with-storage=/var/db/knot \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --disable-silent-rules
+.endif
+
+INSTALL_TARGET= install-strip
+
+USE_RC_SUBR= ${PORTNAME}
+SUB_FILES= pkg-message
+
+USERS= knot
+GROUPS= knot
+SUB_LIST+= USERS="${USERS}" GROUPS="${GROUPS}"
+
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
+
+OPTIONS_DEFINE= DNSTAP FASTPARSER IDN
+
+DNSTAP_DESC= dnstap support (see dnstap.info)
+DNSTAP_CONFIGURE_ENABLE= dnstap
+DNSTAP_LIB_DEPENDS= libfstrm.so:${PORTSDIR}/devel/fstrm \
+ libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c
+
+FASTPARSER_DESC= Fast zone parser (demanding compilation)
+FASTPARSER_CONFIGURE_ENABLE= fastparser
+
+IDN_CONFIGURE_WITH= libidn
+IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+
+post-patch:
+ @${REINPLACE_CMD} 's|$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|#$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} 's|$$(INSTALL) -d $$(DESTDIR)/\@storage_dir\@|#$$(INSTALL) -d $$(DESTDIR)/\@storage_dir\@|' \
+ ${WRKSRC}/src/Makefile.in
+ @${RM} -rf ${WRKSRC}/src/zscanner/scanner.c
+
+post-install:
+ ${MV} ${STAGEDIR}${ETCDIR}/knot.sample.conf \
+ ${STAGEDIR}${ETCDIR}/knot.conf.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>