aboutsummaryrefslogtreecommitdiff
path: root/dns/ldns
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-10-05 10:09:21 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-10-05 10:09:21 +0000
commit42e4920bfe91fe332d26b4e3101132da7b18535c (patch)
tree768cf15e6b60cd6fd4d4656b350f52ba340c1811 /dns/ldns
parent9811ac1bd7d3b56291706080e5b6d0b6be899bd2 (diff)
downloadports-42e4920bfe91fe332d26b4e3101132da7b18535c.tar.gz
ports-42e4920bfe91fe332d26b4e3101132da7b18535c.zip
Avoid dependency on devel/libtool
Notes
Notes: svn path=/head/; revision=370050
Diffstat (limited to 'dns/ldns')
-rw-r--r--dns/ldns/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index bc3c66621bab..4c1936927359 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -14,8 +14,8 @@ COMMENT= Library for programs conforming to DNS RFCs and drafts
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+GNU_CONFIGURE= yes
USES= gmake libtool
-USE_AUTOTOOLS= libtoolize
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -108,15 +108,18 @@ CONFIGURE_ARGS+= --enable-rrtype-ta
.if ! (defined(BUILD_PYLDNS) || defined(BUILD_P5PERL))
post-configure:
+# ac_cv_prog_libtool=../libtool => Always use bundled libtool
.if ${PORT_OPTIONS:MEXAMPLES}
@(cd ${WRKSRC}/examples; ./configure --prefix=${PREFIX} \
--infodir=${PREFIX}/${INFO_PATH} --mandir=${MANPREFIX}/man \
- --build=${CONFIGURE_TARGET} ${NO_GOST} ${NO_SHA2})
+ --build=${CONFIGURE_TARGET} ${NO_GOST} ${NO_SHA2} \
+ ac_cv_prog_libtool=../libtool)
.endif
.if ${PORT_OPTIONS:MDRILL}
@(cd ${WRKSRC}/drill; ./configure --prefix=${PREFIX} \
--mandir=${MANPREFIX}/man \
- --build=${CONFIGURE_TARGET})
+ --build=${CONFIGURE_TARGET} \
+ ac_cv_prog_libtool=../libtool)
.endif
post-build: