aboutsummaryrefslogtreecommitdiff
path: root/dns/libasr
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2019-10-26 16:16:41 +0000
committerDima Panov <fluffy@FreeBSD.org>2019-10-26 16:16:41 +0000
commit2949fde94f9b418b0eb87d892ef1b26b5b872805 (patch)
tree20ba101300656c45cfb0c71408128429a6081100 /dns/libasr
parent623012c977d24d6fe8d138c24f8e88fa6f0b792b (diff)
downloadports-2949fde94f9b418b0eb87d892ef1b26b5b872805.tar.gz
ports-2949fde94f9b418b0eb87d892ef1b26b5b872805.zip
- LibASR doesn't need to depend on *SSL but optional CAroots package
MFH: 2019Q4
Notes
Notes: svn path=/head/; revision=515713
Diffstat (limited to 'dns/libasr')
-rw-r--r--dns/libasr/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/dns/libasr/Makefile b/dns/libasr/Makefile
index ef52b849a325..98ad96d37b90 100644
--- a/dns/libasr/Makefile
+++ b/dns/libasr/Makefile
@@ -3,10 +3,9 @@
PORTNAME= libasr
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns
-MASTER_SITES= http://www.opensmtpd.org/archives/ \
- http://distfiles.pirateparty.in/ashish/
+MASTER_SITES= http://www.opensmtpd.org/archives/
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Asynchronous DNS resolver library
@@ -15,14 +14,26 @@ LICENSE= ISCL BSD4CLAUSE BSD3CLAUSE BSD2CLAUSE
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENCE
+USES= cpe groff libtool
+
CONFLICTS= libasr-devel-[0-9]*
-USES= groff libtool ssl:build
+OPTIONS_DEFINE= CA_BUNDLE
+OPTIONS_DEFAULT= CA_BUNDLE
+
+CA_BUNDLE_DESC= Use NSS CA bundle for SSL instead of /etc/ssl/cert.pem
+
+CPE_VENDOR= openbsd
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-mantype="man"
INSTALL_TARGET= install-strip
-CFLAGS+= -I${OPENSSLINC}
+CA_BUNDLE_CONFIGURE_WITH= ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+
+post-patch:
+ ${REINPLACE_CMD} -e '/opensslv.h/d' ${WRKSRC}/openbsd-compat/includes.h
.include <bsd.port.mk>