aboutsummaryrefslogtreecommitdiff
path: root/dns/libasr
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-02-07 15:54:26 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-02-07 15:54:26 +0000
commit817317c0cf2947466439810b02cb3b53622ac66e (patch)
tree7193638e19b7a7046fc4e3d341f8729befac1b66 /dns/libasr
parent5d4c196112397aea179c2f0cc7853e5045620c59 (diff)
downloadports-817317c0cf2947466439810b02cb3b53622ac66e.tar.gz
ports-817317c0cf2947466439810b02cb3b53622ac66e.zip
Notes
Diffstat (limited to 'dns/libasr')
-rw-r--r--dns/libasr/Makefile24
-rw-r--r--dns/libasr/distinfo2
-rw-r--r--dns/libasr/pkg-descr12
-rw-r--r--dns/libasr/pkg-plist6
4 files changed, 44 insertions, 0 deletions
diff --git a/dns/libasr/Makefile b/dns/libasr/Makefile
new file mode 100644
index 000000000000..45bf89f367f6
--- /dev/null
+++ b/dns/libasr/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libasr
+PORTVERSION= 1.0.1
+CATEGORIES= dns
+MASTER_SITES= http://www.opensmtpd.org/archives/ \
+ http://distfiles.pirateparty.in/ashish/
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= Asynchronous DNS resolver library
+
+LICENSE= ISCL BSD4CLAUSE BSD3CLAUSE BSD2CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+CONFLICTS= libasr-devel-[0-9]*
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/dns/libasr/distinfo b/dns/libasr/distinfo
new file mode 100644
index 000000000000..659f95ad7a10
--- /dev/null
+++ b/dns/libasr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libasr-1.0.1.tar.gz) = 262471e312d623e4951a133ed4c16a74d57f0a02554ca4ed7b4b575456620182
+SIZE (libasr-1.0.1.tar.gz) = 403110
diff --git a/dns/libasr/pkg-descr b/dns/libasr/pkg-descr
new file mode 100644
index 000000000000..8ff137705263
--- /dev/null
+++ b/dns/libasr/pkg-descr
@@ -0,0 +1,12 @@
+libasr is a FREE asynchronous DNS resolver.
+
+libasr runs on top of the OpenBSD operating system but also has a portable
+version that can build and run on several systems, including:
+
+* Linux
+* FreeBSD
+* NetBSD
+* DragonFly
+* MacOSX
+
+WWW: https://github.com/OpenSMTPD/libasr
diff --git a/dns/libasr/pkg-plist b/dns/libasr/pkg-plist
new file mode 100644
index 000000000000..316800a2cce7
--- /dev/null
+++ b/dns/libasr/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+include/asr.h
+lib/libasr.a
+lib/libasr.la
+lib/libasr.so
+lib/libasr.so.0