aboutsummaryrefslogtreecommitdiff
path: root/dns/libidn2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-25 14:22:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-25 14:22:45 +0000
commit6f510c76516732b595a41cd94077c20063310f7b (patch)
tree40d8fdcb2f01148e9a026ec59a74e22aad83b861 /dns/libidn2
parent0ed430cc6b0e15a634b816851a9d276732c845e5 (diff)
downloadports-6f510c76516732b595a41cd94077c20063310f7b.tar.gz
ports-6f510c76516732b595a41cd94077c20063310f7b.zip
Update to 2.0.1
Notes
Notes: svn path=/head/; revision=439384
Diffstat (limited to 'dns/libidn2')
-rw-r--r--dns/libidn2/Makefile26
-rw-r--r--dns/libidn2/distinfo6
-rw-r--r--dns/libidn2/files/patch-src-idn2.c18
-rw-r--r--dns/libidn2/pkg-plist14
4 files changed, 28 insertions, 36 deletions
diff --git a/dns/libidn2/Makefile b/dns/libidn2/Makefile
index 9a6bb2b07492..5ef6437e1a8c 100644
--- a/dns/libidn2/Makefile
+++ b/dns/libidn2/Makefile
@@ -2,19 +2,9 @@
# $FreeBSD$
PORTNAME= libidn2
-PORTVERSION= 0.16
+PORTVERSION= 2.0.1
CATEGORIES= dns
-MASTER_SITES= GNU_ALPHA/libidn \
- https://ftp.iana.org/assignments/idna-tables-6.3.0/:idna_table \
- http://www.unicode.org/Public/6.3.0/ucd/:nfcqc \
- http://www.unicode.org/Public/idna/6.3.0/:test,tr64map \
- LOCAL/sunpoet/${PORTNAME}
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- idna-tables-6.3.0.txt:idna_table \
- DerivedNormalizationProps.txt:nfcqc \
- IdnaTest.txt:test \
- IdnaMappingTable.txt:tr64map
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= GNU/libidn
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Implementation of IDNA2008 internationalized domain names
@@ -22,7 +12,6 @@ COMMENT= Implementation of IDNA2008 internationalized domain names
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= help2man:misc/help2man
LIB_DEPENDS= libunistring.so:devel/libunistring
CONFIGURE_ARGS= --disable-nls \
@@ -30,18 +19,11 @@ CONFIGURE_ARGS= --disable-nls \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-USE_PERL5= build
-USES= charsetfix gmake iconv libtool localbase perl5 shebangfix
+USES= charsetfix gmake iconv libtool localbase pathfix
INFO= libidn2
-SHEBANG_FILES= gen-tables-from-iana.pl tests/gen-utc-test.pl
-
post-patch:
- @cd ${DISTDIR}/ && ${CP} idna-tables-6.3.0.txt IdnaMappingTable.txt DerivedNormalizationProps.txt ${WRKSRC}/
- @cd ${DISTDIR}/ && ${CP} IdnaTest.txt ${WRKSRC}/tests/
-
-post-install:
- @${RM} ${STAGEDIR}${PREFIX}/bin/idn2_noinstall
+ @${REINPLACE_CMD} -e '/^TMPDIR = /d' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/dns/libidn2/distinfo b/dns/libidn2/distinfo
index 0a57829ded33..fda1f89ed0cf 100644
--- a/dns/libidn2/distinfo
+++ b/dns/libidn2/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1484743810
-SHA256 (libidn2-0.16.tar.gz) = 2fad9efff4082ae2143f69df76339ca99379e0e0f4231455f5d3d9d2089c688f
-SIZE (libidn2-0.16.tar.gz) = 1494295
+TIMESTAMP = 1492968618
+SHA256 (libidn2-2.0.1.tar.gz) = 0d23651415556508168f15fa0299b54bb8015a3953a23c1ffdfe09f12c27f1d3
+SIZE (libidn2-2.0.1.tar.gz) = 1770164
SHA256 (idna-tables-6.3.0.txt) = ac67b5bf7c2de2d3b6e11fa7bf0d7ba54e6457788aec1ebde48739ee084822b7
SIZE (idna-tables-6.3.0.txt) = 162415
SHA256 (DerivedNormalizationProps.txt) = c5e867ae043fe5d1cf713150d859356bfdcdba291c39f584af0bfb943f1a9743
diff --git a/dns/libidn2/files/patch-src-idn2.c b/dns/libidn2/files/patch-src-idn2.c
index 1447e61d430e..fbdc68f56e6a 100644
--- a/dns/libidn2/files/patch-src-idn2.c
+++ b/dns/libidn2/files/patch-src-idn2.c
@@ -1,7 +1,7 @@
---- src/idn2.c.orig 2016-12-26 21:00:11 UTC
+--- src/idn2.c.orig 2017-04-12 18:43:32 UTC
+++ src/idn2.c
-@@ -31,7 +31,7 @@
- #include <unistr.h>
+@@ -33,7 +33,7 @@
+ #include <unistring/localcharset.h>
/* Gnulib headers. */
-#include "error.h"
@@ -9,16 +9,16 @@
#include "gettext.h"
#define _(String) dgettext (PACKAGE, String)
#include "progname.h"
-@@ -167,7 +167,7 @@ process_input (char *readbuf, int flags)
+@@ -176,7 +176,7 @@ process_input (char *readbuf, int flags)
free (output);
}
else
-- error (EXIT_FAILURE, 0, "%s: %s",
-+ errc (EXIT_FAILURE, 0, "%s: %s",
- args_info.register_given ? "register" : "lookup",
- idn2_strerror (rc));
+- error (EXIT_FAILURE, 0, "%s: %s", tag, idn2_strerror (rc));
++ errc (EXIT_FAILURE, 0, "%s: %s", tag, idn2_strerror (rc));
}
-@@ -228,7 +228,7 @@ main (int argc, char *argv[])
+
+ int
+@@ -237,7 +237,7 @@ main (int argc, char *argv[])
}
if (ferror (stdin))
diff --git a/dns/libidn2/pkg-plist b/dns/libidn2/pkg-plist
index d5f406a9883c..db97c302e33b 100644
--- a/dns/libidn2/pkg-plist
+++ b/dns/libidn2/pkg-plist
@@ -3,7 +3,8 @@ include/idn2.h
lib/libidn2.a
lib/libidn2.so
lib/libidn2.so.0
-lib/libidn2.so.0.1.4
+lib/libidn2.so.0.3.0
+libdata/pkgconfig/libidn2.pc
man/man1/idn2.1.gz
man/man3/idn2_check_version.3.gz
man/man3/idn2_free.3.gz
@@ -13,10 +14,19 @@ man/man3/idn2_register_u8.3.gz
man/man3/idn2_register_ul.3.gz
man/man3/idn2_strerror.3.gz
man/man3/idn2_strerror_name.3.gz
+man/man3/idn2_to_ascii_4i.3.gz
+man/man3/idn2_to_ascii_4z.3.gz
+man/man3/idn2_to_ascii_8z.3.gz
+man/man3/idn2_to_ascii_lz.3.gz
+man/man3/idn2_to_unicode_44i.3.gz
+man/man3/idn2_to_unicode_4z4z.3.gz
+man/man3/idn2_to_unicode_8z4z.3.gz
+man/man3/idn2_to_unicode_8z8z.3.gz
+man/man3/idn2_to_unicode_8zlz.3.gz
+man/man3/idn2_to_unicode_lzlz.3.gz
share/gtk-doc/html/libidn2/api-index-full.html
share/gtk-doc/html/libidn2/home.png
share/gtk-doc/html/libidn2/index.html
-share/gtk-doc/html/libidn2/index.sgml
share/gtk-doc/html/libidn2/left-insensitive.png
share/gtk-doc/html/libidn2/left.png
share/gtk-doc/html/libidn2/libidn2-idn2.html