aboutsummaryrefslogtreecommitdiff
path: root/dns/libidn
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-09 19:26:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-09 19:26:31 +0000
commit2d9fc12a5ccbee8f0bd1bfc6f6efa459a98a38cb (patch)
tree4ab8b504ceb01d503fba0dd3600185c6445fe351 /dns/libidn
parentfda85fbb68d3fce7998109a17c36260fab330d73 (diff)
downloadports-2d9fc12a5ccbee8f0bd1bfc6f6efa459a98a38cb.tar.gz
ports-2d9fc12a5ccbee8f0bd1bfc6f6efa459a98a38cb.zip
Notes
Diffstat (limited to 'dns/libidn')
-rw-r--r--dns/libidn/Makefile4
-rw-r--r--dns/libidn/distinfo2
-rw-r--r--dns/libidn/files/patch-configure10
-rw-r--r--dns/libidn/files/patch-ltmain.sh15
4 files changed, 18 insertions, 13 deletions
diff --git a/dns/libidn/Makefile b/dns/libidn/Makefile
index 62096bcfe470..9b38f20f206a 100644
--- a/dns/libidn/Makefile
+++ b/dns/libidn/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libidn
-PORTVERSION= 0.3.3
-PORTREVISION= 1
+PORTVERSION= 0.3.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA} \
http://josefsson.org/libidn/releases/
@@ -21,6 +20,7 @@ BUILD_DEPENDS= gengetopt:${PORTSDIR}/devel/gengetopt
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_GETOPT_LONG= yes
USE_GNOME= gnomehack
diff --git a/dns/libidn/distinfo b/dns/libidn/distinfo
index 34d2fb8263f9..656e901b09f2 100644
--- a/dns/libidn/distinfo
+++ b/dns/libidn/distinfo
@@ -1 +1 @@
-MD5 (libidn-0.3.3.tar.gz) = aae37748904f8fe944b01de4461b0034
+MD5 (libidn-0.3.4.tar.gz) = 0b2e1df28f86cdeb3b8e34770b652342
diff --git a/dns/libidn/files/patch-configure b/dns/libidn/files/patch-configure
deleted file mode 100644
index 988fda9f1352..000000000000
--- a/dns/libidn/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Fri Jul 25 17:30:46 2003
-+++ configure Fri Jul 25 17:31:45 2003
-@@ -7788,6 +7788,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/dns/libidn/files/patch-ltmain.sh b/dns/libidn/files/patch-ltmain.sh
new file mode 100644
index 000000000000..6970f3e4a727
--- /dev/null
+++ b/dns/libidn/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Sun Nov 9 20:11:04 2003
++++ ltmain.sh Sun Nov 9 20:12:16 2003
+@@ -5668,10 +5668,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"