aboutsummaryrefslogtreecommitdiff
path: root/dns/libpsl
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-01-28 21:51:24 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-01-28 21:53:05 +0000
commit5e44dbd2e287d4f9529853284db9102ab6a34e18 (patch)
tree53d81d40b8b4883e161b189e7e4e083b819e7313 /dns/libpsl
parent862511e5784e381e08d88246358188dfcffc6901 (diff)
downloadports-5e44dbd2e287d4f9529853284db9102ab6a34e18.tar.gz
ports-5e44dbd2e287d4f9529853284db9102ab6a34e18.zip
dns/libpsl: Update to 0.21.5
Adjust Makefile to follow Porters Handbook more closely and for readability Changelog: https://github.com/rockdaboot/libpsl/releases/tag/0.21.5 PR: 276315 Approved by: portmgr (maintainer timeout, 2+ weeks)
Diffstat (limited to 'dns/libpsl')
-rw-r--r--dns/libpsl/Makefile21
-rw-r--r--dns/libpsl/distinfo6
-rw-r--r--dns/libpsl/pkg-plist2
3 files changed, 15 insertions, 14 deletions
diff --git a/dns/libpsl/Makefile b/dns/libpsl/Makefile
index 67ad7267bc56..763039335bb2 100644
--- a/dns/libpsl/Makefile
+++ b/dns/libpsl/Makefile
@@ -1,8 +1,7 @@
PORTNAME= libpsl
-PORTVERSION= 0.21.2
-PORTREVISION= 5
+DISTVERSION= 0.21.5
CATEGORIES= dns
-MASTER_SITES= https://github.com/rockdaboot/libpsl/releases/download/${PORTVERSION}/
+MASTER_SITES= https://github.com/rockdaboot/${PORTNAME}/releases/download/${DISTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C library to handle the Public Suffix List
@@ -14,17 +13,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
USES= localbase:ldflags meson pkgconfig python:build shebangfix tar:lz
+SHEBANG_FILES= src/psl-make-dafsa
+USE_LDCONFIG= yes
+
+USE_LOCALE= en_US.UTF-8
+TEST_TARGET= test
MESON_ARGS= --default-library=both \
-Dbuiltin=true \
-Ddocs=false \
-Dpsl_file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
-Dpsl_testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
-USE_LDCONFIG= yes
-USE_LOCALE= en_US.UTF-8
-
-SHEBANG_FILES= src/psl-make-dafsa
-TEST_TARGET= test
OPTIONS_SINGLE= IDNA
OPTIONS_SINGLE_IDNA= ICU IDN IDN2
@@ -35,14 +34,16 @@ IDN2_DESC= Use dns/libidn2 (IDNA2008 library)
ICU_LIB_DEPENDS= libicuuc.so:devel/icu
ICU_MESON_ON= -Druntime=libicu
+
+IDN_USES= iconv
IDN_LIB_DEPENDS= libidn.so:dns/libidn \
libunistring.so:devel/libunistring
IDN_MESON_ON= -Druntime=libidn
-IDN_USES= iconv
+
+IDN2_USES= iconv
IDN2_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
IDN2_MESON_ON= -Druntime=libidn2
-IDN2_USES= iconv
post-install:
${RM} ${STAGEDIR}${PREFIX}/bin/psl-make-dafsa ${STAGEDIR}${PREFIX}/share/man/man1/psl-make-dafsa.1
diff --git a/dns/libpsl/distinfo b/dns/libpsl/distinfo
index 04b41c69ec42..1174e1712290 100644
--- a/dns/libpsl/distinfo
+++ b/dns/libpsl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1672063633
-SHA256 (libpsl-0.21.2.tar.lz) = aa3d706c452786d1345e094dae201cd36d81f03cf81d636d5cfc10d365907f17
-SIZE (libpsl-0.21.2.tar.lz) = 2039147
+TIMESTAMP = 1705224525
+SHA256 (libpsl-0.21.5.tar.lz) = 9a9f6a8c6edba650cf9ea55475cd172dd28487316804e9c73202d97572cd3a2d
+SIZE (libpsl-0.21.5.tar.lz) = 2016549
diff --git a/dns/libpsl/pkg-plist b/dns/libpsl/pkg-plist
index ffaaa2161dd4..b29fbd0717ba 100644
--- a/dns/libpsl/pkg-plist
+++ b/dns/libpsl/pkg-plist
@@ -3,6 +3,6 @@ include/libpsl.h
lib/libpsl.a
lib/libpsl.so
lib/libpsl.so.5
-lib/libpsl.so.5.3.4
+lib/libpsl.so.5.3.5
libdata/pkgconfig/libpsl.pc
share/man/man1/psl.1.gz