aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns-ng
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-11-12 07:03:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-11-12 07:03:31 +0000
commitf0ba571ea0655902f0be8d85c6831762f142de5d (patch)
treee1821e5f1eacb01254db1f5eee3f7442f2ebf00d /dns/mydns-ng
parentdeb68d2d0d227efda609a52d2b2f7ab452fd56a0 (diff)
downloadports-f0ba571ea0655902f0be8d85c6831762f142de5d.tar.gz
ports-f0ba571ea0655902f0be8d85c6831762f142de5d.zip
- Unbreak the build with -fno-common (Clang 11, GCC 10)
- Fix bogus use of capital letters in the COMMENT text - Unmute installation commands, wrap an overly long line PR: 249356 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=554933
Diffstat (limited to 'dns/mydns-ng')
-rw-r--r--dns/mydns-ng/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index 2fc641a492b5..a23c0828cabe 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/mydns/${PORTVERSION}
DISTNAME= mydns-${PORTVERSION}
MAINTAINER= gaod@hychen.org
-COMMENT= Next Generation DNS Server for sql based DNS services
+COMMENT= Next generation DNS server for SQL-based DNS services
LICENSE= GPLv2
@@ -51,15 +51,18 @@ MYSQL_CONFIGURE_OFF= --without-mysql
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+post-patch:
+# Fix the build with -fno-common (for Clang 11 and GCC 10)
+ @${REINPLACE_CMD} -e '/^CONF \*Conf/d' ${WRKSRC}/src/util/util.c
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/contrib
.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.php ${STAGEDIR}${DOCSDIR}/contrib/
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.pl ${STAGEDIR}${DOCSDIR}/contrib/
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.pm ${STAGEDIR}${DOCSDIR}/contrib/
- @${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/contrib/
- @${STAGEDIR}${PREFIX}/sbin/mydns --dump-config > ${STAGEDIR}${PREFIX}/etc/mydns.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/contrib/*.p* ${STAGEDIR}${DOCSDIR}/contrib
+ ${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/contrib
+ ${STAGEDIR}${PREFIX}/sbin/mydns --dump-config > \
+ ${STAGEDIR}${PREFIX}/etc/mydns.conf.sample
.include <bsd.port.mk>