aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 22:27:05 +0000
commit9ff06b3cbf038359059e40e0db31ba0cbe996d0f (patch)
tree8583dfe71adaea6ce266633e1799cd602516b801 /dns/mydns
parent25c4307da135103ea810d65f96f2f1c21e0547b4 (diff)
downloadports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.tar.gz
ports-9ff06b3cbf038359059e40e0db31ba0cbe996d0f.zip
Convert a bunch of ports from WITHOUT_NLS -> ${PORT_OPTIONS:MNLS}
While here: - trim headers - convert to new options framework
Notes
Notes: svn path=/head/; revision=316850
Diffstat (limited to 'dns/mydns')
-rw-r--r--dns/mydns/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index afbeced56410..d72546eba859 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mydns
-# Date created: 23 July 2002
-# Whom: Simon Dick <simond@irrelevant.org>
-#
+# Created by: Simon Dick <simond@irrelevant.org>
# $FreeBSD$
-#
PORTNAME= mydns
PORTVERSION= 1.1.0
@@ -30,18 +26,18 @@ MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8 mydnsptrconvert.8 mydns-
DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
-.if defined(WITH_ALIAS)
+.if ${PORT_OPTIONS:MALIAS}
CONFIGURE_ARGS+=--enable-alias
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-openssl \
--with-openssl-include=${OPENSSLINC} \
--with-openssl-lib=${OPENSSLLIB}
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+=--without-mysql \
--with-pgsql-include=${LOCALBASE}/include \
@@ -55,7 +51,7 @@ PKGNAMESUFFIX= -mysql
USE_MYSQL= yes
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -73,7 +69,7 @@ pre-fetch:
@${ECHO} ""
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/contrib
.for f in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/