aboutsummaryrefslogtreecommitdiff
path: root/dns/noip
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-11 18:09:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-11 18:09:00 +0000
commit35f74fbe2efdf35c73e4ea16384ab1499fb17df0 (patch)
tree9cac7f5ea213c17593d4d5a8c733bc92daf9a6ef /dns/noip
parent70e5afba3d6e5c3b47408f4a92c9f510719e0ccf (diff)
downloadports-35f74fbe2efdf35c73e4ea16384ab1499fb17df0.tar.gz
ports-35f74fbe2efdf35c73e4ea16384ab1499fb17df0.zip
- Convert to option helper install target (add OPTIONS_DEFINE=DOCS
when it was missing) - Invoke INSTALL_DATA where appropriate instead of INSTALL_MAN - Fix some whitespace and formatting bugs along the way
Notes
Notes: svn path=/head/; revision=458761
Diffstat (limited to 'dns/noip')
-rw-r--r--dns/noip/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index 8322669284ad..45364a3a02b8 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -27,9 +27,11 @@ OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/noip2 ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README.FIRST ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.FIRST ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
conf:
(cd ${PREFIX}/etc && ${PREFIX}/bin/noip2 -C)