aboutsummaryrefslogtreecommitdiff
path: root/dns/noip
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-26 21:26:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-26 21:26:58 +0000
commitc5d48bda022b65451f4f5bba5ac4395fdeff0e70 (patch)
tree2caa9431338493403f7952cbc6ebd6b156a57df1 /dns/noip
parent986ca89b9c26c04aee72873b9f44f417f24ecabb (diff)
downloadports-c5d48bda022b65451f4f5bba5ac4395fdeff0e70.tar.gz
ports-c5d48bda022b65451f4f5bba5ac4395fdeff0e70.zip
- Update to 2.1.4
PR: 109533 Submitted by: Kay Abendroth <kay.abendroth@raxion.net> (maintainer)
Notes
Notes: svn path=/head/; revision=186029
Diffstat (limited to 'dns/noip')
-rw-r--r--dns/noip/Makefile2
-rw-r--r--dns/noip/distinfo6
-rw-r--r--dns/noip/files/patch-noip2.c14
3 files changed, 11 insertions, 11 deletions
diff --git a/dns/noip/Makefile b/dns/noip/Makefile
index 96df420fc122..b26c613e33ed 100644
--- a/dns/noip/Makefile
+++ b/dns/noip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= noip
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/dns/noip/distinfo b/dns/noip/distinfo
index 41d6f7a109ff..16b32dba9331 100644
--- a/dns/noip/distinfo
+++ b/dns/noip/distinfo
@@ -1,3 +1,3 @@
-MD5 (noip-2.1.3.tar.gz) = 550601f1891c8900439e2404b7d27418
-SHA256 (noip-2.1.3.tar.gz) = 1b72ab33cd9b84b19eb08ca7c4358ce192789255e656d105cb8b508f6c5c1395
-SIZE (noip-2.1.3.tar.gz) = 101286
+MD5 (noip-2.1.4.tar.gz) = d65e221016a61cd4e412242c34c71ff1
+SHA256 (noip-2.1.4.tar.gz) = 8912301be611b842d0cf1a335275c367f3a80d507bc53c7460c68b52d71b1a7c
+SIZE (noip-2.1.4.tar.gz) = 102789
diff --git a/dns/noip/files/patch-noip2.c b/dns/noip/files/patch-noip2.c
index ebdc8f1e7270..f745e1aabb76 100644
--- a/dns/noip/files/patch-noip2.c
+++ b/dns/noip/files/patch-noip2.c
@@ -1,15 +1,15 @@
---- noip2.c.orig Fri Feb 24 16:45:23 2006
-+++ noip2.c Wed Oct 18 11:12:03 2006
-@@ -170,7 +170,7 @@
+--- noip2.c.orig Tue Feb 20 22:12:22 2007
++++ noip2.c Sun Feb 25 18:47:38 2007
+@@ -176,7 +176,7 @@
#define CLIENT_IP_PORT 8245
- #define VERSION "2.1.3"
+ #define VERSION "2.1.4"
-#define USER_AGENT "User-Agent: Linux-DUC/"VERSION
+#define USER_AGENT "User-Agent: FreeBSD-DUC/"VERSION
#define SETTING_SCRIPT "settings.php?"
#define USTRNG "username="
#define PWDSTRNG "&pass="
-@@ -278,7 +278,7 @@
+@@ -283,7 +283,7 @@
#define CMSG21 "Please select the Internet interface from this list.\n"
#define CMSG22 "By typing the number associated with it."
#define CMSG23 "Too many network devices. Limit is %d"
@@ -18,7 +18,7 @@
#define CMSG25 "Can't create config file (%s)"
#define CMSG25a "Re-run noip, adding '-c configfilename' as a parameter."
#define CMSG26 "Can't rename config file (%s)"
-@@ -484,7 +484,7 @@
+@@ -490,7 +490,7 @@
fprintf(stderr, "[ -d][ -D pid]");
#endif
fprintf(stderr, "[ -i addr][ -S][ -M][ -h]");
@@ -27,7 +27,7 @@
fprintf(stderr, "Options: -C create configuration data\n");
fprintf(stderr, " -F force NAT off\n");
fprintf(stderr, " -Y select all hosts/groups\n");
-@@ -2040,17 +2040,12 @@
+@@ -2058,17 +2058,12 @@
dq = (unsigned char *)devs; // point at name list
for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
if (ifa->ifa_addr->sa_family == AF_LINK) {