aboutsummaryrefslogtreecommitdiff
path: root/dns/nslint
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-15 00:20:12 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-15 00:20:12 +0000
commit9678ac98669db37961dd335816b1bc41b233cf03 (patch)
treeb6ab825263226cc59a7f1810879fd36f720f6938 /dns/nslint
parente04df4c6cbed4e66a301758120f2f5229b234cd3 (diff)
downloadports-9678ac98669db37961dd335816b1bc41b233cf03.tar.gz
ports-9678ac98669db37961dd335816b1bc41b233cf03.zip
- Update to 2.1.a6
- Let the user define BOOTFILE (default: /etc/namedb/named.boot) - Let the user define CONFFILE (default: /etc/namedb/named.conf) - Fully respect CFLAGS - Remove two patches - Add an additional master site - Adopt this port
Notes
Notes: svn path=/head/; revision=159530
Diffstat (limited to 'dns/nslint')
-rw-r--r--dns/nslint/Makefile21
-rw-r--r--dns/nslint/distinfo6
-rw-r--r--dns/nslint/files/patch-ab21
-rw-r--r--dns/nslint/files/patch-ac50
4 files changed, 20 insertions, 78 deletions
diff --git a/dns/nslint/Makefile b/dns/nslint/Makefile
index 37ad53c26da9..3782160db054 100644
--- a/dns/nslint/Makefile
+++ b/dns/nslint/Makefile
@@ -6,18 +6,31 @@
#
PORTNAME= nslint
-PORTVERSION= 2.1.a3
+PORTVERSION= 2.1.a6
CATEGORIES= dns
-MASTER_SITES= ftp://ftp.ee.lbl.gov/
+MASTER_SITES= ftp://ftp.ee.lbl.gov/ \
+ http://critical.ch/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a/a/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Perform consistency checks on DNS zone files
GNU_CONFIGURE= yes
-ALL_TARGET= nslint
+
+ALL_TARGET= ${PORTNAME}
INSTALL_TARGET= install install-man
+
+BOOTFILE?= /etc/namedb/named.boot
+CONFFILE?= /etc/namedb/named.conf
+
MAN8= nslint.8
PLIST_FILES= bin/nslint
+post-patch:
+ ${REINPLACE_CMD} -e '/^\ \{4\}V_CCOPT/d' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|/etc/named.boot|${BOOTFILE}|; \
+ s|/etc/named.conf|${CONFFILE}|' \
+ ${WRKSRC}/${PORTNAME}.c \
+ ${WRKSRC}/${MAN8}
+
.include <bsd.port.mk>
diff --git a/dns/nslint/distinfo b/dns/nslint/distinfo
index ed09e902bcac..c11a73aa8001 100644
--- a/dns/nslint/distinfo
+++ b/dns/nslint/distinfo
@@ -1,3 +1,3 @@
-MD5 (nslint-2.1a3.tar.gz) = 87f78dd8680a4abbc480d814172a468e
-SHA256 (nslint-2.1a3.tar.gz) = f01545c54237727c626ae011209362004762f6a8bb95aa4d8167ede998571cd7
-SIZE (nslint-2.1a3.tar.gz) = 59768
+MD5 (nslint-2.1a6.tar.gz) = ebd860efae831147b095f53d81fb9947
+SHA256 (nslint-2.1a6.tar.gz) = b06f1ad32743984ffba7803136414a3e63156fc4a2403e7f38893337547ef2ce
+SIZE (nslint-2.1a6.tar.gz) = 87935
diff --git a/dns/nslint/files/patch-ab b/dns/nslint/files/patch-ab
deleted file mode 100644
index 9e2a3c8a87f9..000000000000
--- a/dns/nslint/files/patch-ab
+++ /dev/null
@@ -1,21 +0,0 @@
-*** nslint.c.orig Wed Sep 24 20:41:28 1997
---- nslint.c Mon Oct 27 09:18:05 1997
-***************
-*** 127,134 ****
-
- int debug;
- int errors;
-! char *bootfile = "/etc/named.boot";
-! char *conffile = "/etc/named.conf";
- char *nslintboot;
- char *nslintconf;
- char *prog;
---- 127,134 ----
-
- int debug;
- int errors;
-! char *bootfile = "/etc/namedb/named.boot";
-! char *conffile = "/etc/namedb/named.conf";
- char *nslintboot;
- char *nslintconf;
- char *prog;
diff --git a/dns/nslint/files/patch-ac b/dns/nslint/files/patch-ac
deleted file mode 100644
index 0e42b54a654d..000000000000
--- a/dns/nslint/files/patch-ac
+++ /dev/null
@@ -1,50 +0,0 @@
-*** nslint.8.orig Tue Feb 23 15:05:17 1999
---- nslint.8 Sun Jan 2 14:48:23 2000
-***************
-*** 101,114 ****
- Specify an alternate
- .I named.boot
- file. The default is
-! .IR /etc/named.boot .
- .TP
- .TP
- .B -c
- Specify an alternate
- .I named.conf
- file. The default is
-! .IR /etc/named.conf .
- .TP
- .B -B
- Specify an alternate
---- 101,114 ----
- Specify an alternate
- .I named.boot
- file. The default is
-! .IR /etc/namedb/named.boot .
- .TP
- .TP
- .B -c
- Specify an alternate
- .I named.conf
- file. The default is
-! .IR /etc/namedb/named.conf .
- .TP
- .B -B
- Specify an alternate
-***************
-*** 398,404 ****
- .na
- .nh
- .nf
-! /etc/named.boot - default named configuration file
- nslint.boot - default nslint configuration file
- .ad
- .hy
---- 398,404 ----
- .na
- .nh
- .nf
-! /etc/namedb/named.boot - default named configuration file
- nslint.boot - default nslint configuration file
- .ad
- .hy