aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-DNS-EasyDNS
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-28 20:10:52 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-28 20:10:52 +0000
commita2000d4d0977e71147f11990db6f75f10ccf0bba (patch)
tree0df1c42b228d40ec17552734b985533c285312e3 /dns/p5-DNS-EasyDNS
parent950d1f7bd113f75c16c5a511ef8579a022becd0a (diff)
downloadports-a2000d4d0977e71147f11990db6f75f10ccf0bba.tar.gz
ports-a2000d4d0977e71147f11990db6f75f10ccf0bba.zip
Adding port dns/p5-DNS-EasyDNS, Update your EasyDNS dynamic DNS entries.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163767
Diffstat (limited to 'dns/p5-DNS-EasyDNS')
-rw-r--r--dns/p5-DNS-EasyDNS/Makefile38
-rw-r--r--dns/p5-DNS-EasyDNS/distinfo2
-rw-r--r--dns/p5-DNS-EasyDNS/pkg-descr6
-rw-r--r--dns/p5-DNS-EasyDNS/pkg-plist9
4 files changed, 55 insertions, 0 deletions
diff --git a/dns/p5-DNS-EasyDNS/Makefile b/dns/p5-DNS-EasyDNS/Makefile
new file mode 100644
index 000000000000..d101325271fc
--- /dev/null
+++ b/dns/p5-DNS-EasyDNS/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-DNS-EasyDNS
+# Date created: 28 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DNS-EasyDNS
+PORTVERSION= 0.04
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DNS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Update your EasyDNS dynamic DNS entries
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= DNS::EasyDNS.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/p5-DNS-EasyDNS/distinfo b/dns/p5-DNS-EasyDNS/distinfo
new file mode 100644
index 000000000000..dc54629da26c
--- /dev/null
+++ b/dns/p5-DNS-EasyDNS/distinfo
@@ -0,0 +1,2 @@
+MD5 (DNS-EasyDNS-0.04.tar.gz) = d7b207c9bef13886434f2835ef08d96b
+SIZE (DNS-EasyDNS-0.04.tar.gz) = 5850
diff --git a/dns/p5-DNS-EasyDNS/pkg-descr b/dns/p5-DNS-EasyDNS/pkg-descr
new file mode 100644
index 000000000000..3c5b13ee5860
--- /dev/null
+++ b/dns/p5-DNS-EasyDNS/pkg-descr
@@ -0,0 +1,6 @@
+This module allows you to update your EasyDNS ( http://www.easydns.com/ )
+dynamic DNS records. This is done via an http get using the libwww-perl
+modules.
+
+WWW: http://search.cpan.org/dist/DNS-EasyDNS
+Author: Gavin Brock <gbrock@cpan.org>
diff --git a/dns/p5-DNS-EasyDNS/pkg-plist b/dns/p5-DNS-EasyDNS/pkg-plist
new file mode 100644
index 000000000000..e4ce7de8e1f2
--- /dev/null
+++ b/dns/p5-DNS-EasyDNS/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/DNS/EasyDNS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS/EasyDNS/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/easydns-by-interface
+%%PORTDOCS%%%%EXAMPLESDIR%%/easydns-from-router
+%%PORTDOCS%%%%EXAMPLESDIR%%/easydns-simple
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS/EasyDNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS
+@dirrmtry %%SITE_PERL%%/DNS