aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-DNS-ZoneParse/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-07-15 13:37:58 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-07-15 13:37:58 +0000
commit60e2cc76185f1fdef56707c6696636ef208ec041 (patch)
treeae7734aecc57eb7642b8c7fe729a331870c37961 /dns/p5-DNS-ZoneParse/Makefile
parent7aa540c0a76fae6f403a469eb3f637ee7d3c4f49 (diff)
Notes
Diffstat (limited to 'dns/p5-DNS-ZoneParse/Makefile')
-rw-r--r--dns/p5-DNS-ZoneParse/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/dns/p5-DNS-ZoneParse/Makefile b/dns/p5-DNS-ZoneParse/Makefile
new file mode 100644
index 000000000000..0d3a15e22001
--- /dev/null
+++ b/dns/p5-DNS-ZoneParse/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-DNS-ZoneParse
+# Date created: 15 July 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DNS-ZoneParse
+PORTVERSION= 0.91
+CATEGORIES= dns textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DNS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Parse and manipulate DNS Zone Files
+
+PERL_CONFIGURE= yes
+
+MAN3= DNS::ZoneParse.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>