aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-Net-DNS-ZoneCheck/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-10-14 19:24:46 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-10-14 19:24:46 +0000
commitc11d0beab860d1d9eb0f6e8f6956c7fe67506f1d (patch)
tree35fc638f3ce2485b530c6c1fdbae31c5bcf5f5c6 /dns/p5-Net-DNS-ZoneCheck/Makefile
parent4faa925e166290ae3a40d9e073acc3c589ae0c58 (diff)
Add p5-Net-DNS-ZoneCheck, a perl module to validate a DNS zone composed
of RR records.
Notes
Notes: svn path=/head/; revision=119440
Diffstat (limited to 'dns/p5-Net-DNS-ZoneCheck/Makefile')
-rw-r--r--dns/p5-Net-DNS-ZoneCheck/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/dns/p5-Net-DNS-ZoneCheck/Makefile b/dns/p5-Net-DNS-ZoneCheck/Makefile
new file mode 100644
index 000000000000..b64bfa94c353
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneCheck/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dns/p5-Net-DNS-ZoneCheck
+# Date created: 14 October 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-ZoneCheck
+PORTVERSION= 0.01
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Validate a DNS zone composed of Net::DNS::RR records
+
+BUILD_DEPENDS= ${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
+ ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNS::ZoneCheck.3
+
+.include <bsd.port.mk>