aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-POE-Component-Client-DNSBL
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-01 16:34:33 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-01 16:34:33 +0000
commite43571dc73b46960ec6966e07753aaac4ad8ef97 (patch)
treefe8bf5331062ac0958dd92f0997f82aefcff6bf4 /dns/p5-POE-Component-Client-DNSBL
parentfdb4c8b64383f766548b565efe2df6f39dddd8d5 (diff)
downloadports-e43571dc73b46960ec6966e07753aaac4ad8ef97.tar.gz
ports-e43571dc73b46960ec6966e07753aaac4ad8ef97.zip
A Perl POE component that provides non-blocking DNSBL lookups
Notes
Notes: svn path=/head/; revision=292496
Diffstat (limited to 'dns/p5-POE-Component-Client-DNSBL')
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/Makefile26
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/distinfo2
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/pkg-descr3
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/pkg-plist3
4 files changed, 34 insertions, 0 deletions
diff --git a/dns/p5-POE-Component-Client-DNSBL/Makefile b/dns/p5-POE-Component-Client-DNSBL/Makefile
new file mode 100644
index 000000000000..eb8b1ac631d5
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-POE-Component-Client-DNSBL
+# Date created: 2012-03-01
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-DNSBL
+PORTVERSION= 1.08
+CATEGORIES= dns perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A Perl POE component that provides non-blocking DNSBL lookups
+
+BUILD_DEPENDS= p5-POE>=1.004:${PORTSDIR}/devel/p5-POE \
+ p5-Net-IP-Minimal>=0:${PORTSDIR}/net/p5-Net-IP-Minimal \
+ p5-POE-Component-Client-DNS>=0:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::DNSBL.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-POE-Component-Client-DNSBL/distinfo b/dns/p5-POE-Component-Client-DNSBL/distinfo
new file mode 100644
index 000000000000..8729b3d941ac
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-Client-DNSBL-1.08.tar.gz) = 4006f4d377e5c012fc183ee4ea7396c43b5544ac8f07060daaf8880908e104b5
+SIZE (POE-Component-Client-DNSBL-1.08.tar.gz) = 15107
diff --git a/dns/p5-POE-Component-Client-DNSBL/pkg-descr b/dns/p5-POE-Component-Client-DNSBL/pkg-descr
new file mode 100644
index 000000000000..660efc9d58bd
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/pkg-descr
@@ -0,0 +1,3 @@
+A Perl POE component that provides non-blocking DNSBL lookups
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-DNSBL/
diff --git a/dns/p5-POE-Component-Client-DNSBL/pkg-plist b/dns/p5-POE-Component-Client-DNSBL/pkg-plist
new file mode 100644
index 000000000000..531d1d364af9
--- /dev/null
+++ b/dns/p5-POE-Component-Client-DNSBL/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/POE/Component/Client/DNSBL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNSBL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/DNSBL